Bug 1286418 - "openstack overcloud --help" returns an error: 'ArgumentParser' object has no attribute 'debug'
"openstack overcloud --help" returns an error: 'ArgumentParser' object has no...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity medium
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
:
: 1286420 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-29 05:25 EST by Udi
Modified: 2016-10-14 18:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 18:23:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2015-11-29 05:25:14 EST
Description of problem:
I ran "openstack overcloud --help" and it printed this in the end:

Could not load EntryPoint.parse('overcloud_netenv_validate = rdomanager_oscplugin.v1.overcloud_netenv_validate:ValidateOvercloudNetenv')
ERROR: openstack 'ArgumentParser' object has no attribute 'debug'


Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.10-19.el7ost.noarch


How reproducible:
100% 


Steps to Reproduce:
1. Run "openstack overcloud --help"
Comment 2 Mike Burns 2015-11-30 09:03:32 EST
*** Bug 1286420 has been marked as a duplicate of this bug. ***
Comment 3 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Jason E. Rist 2016-10-14 18:23:55 EDT
This is working in the current release.
[stack@instack tripleo-common]$ openstack overcloud --help
WARNING: openstackclient.common.utils is deprecated and will be removed after Jun 2017. Please use osc_lib.utils
Command "overcloud" matches:
  overcloud deploy
  overcloud execute
  overcloud image build
  overcloud image upload
  overcloud netenv validate
  overcloud node configure
  overcloud node delete
  overcloud node import
  overcloud node introspect
  overcloud node provide
  overcloud plan create
  overcloud plan delete
  overcloud plan list
  overcloud profiles list
  overcloud profiles match
  overcloud update stack
  overcloud upgrade

Note You need to log in before you can comment on or make changes to this bug.