Bug 1286517 - cli/geo-rep : remove unused code
Summary: cli/geo-rep : remove unused code
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.7.6
Hardware: All
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard:
Depends On: 1285968
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-30 06:14 UTC by Manikandan
Modified: 2016-09-20 04:28 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1285968
Environment:
Last Closed: 2016-02-16 08:39:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Manikandan 2015-11-30 06:14:37 UTC
+++ This bug was initially created as a clone of Bug #1285968 +++

Description of problem:

In cli-rpc-ops.c, gf_cli_gsync_set_cbk(), unused code is there.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2015-11-27 00:49:10 EST ---

REVIEW: http://review.gluster.org/12771 (cli/geo-rep : remove unused code) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-27 04:44:30 EST ---

COMMIT: http://review.gluster.org/12771 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 87845356171afcd07f62f46dd81596e4f71e7935
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Fri Nov 27 11:18:00 2015 +0530

    cli/geo-rep : remove unused code
    
    Change-Id: I8a8e27b4d6c35ea5e57bd0b556fd2c6ab7b496ab
    BUG: 1285968
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12771
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 1 Vijay Bellur 2015-11-30 06:21:51 UTC
REVIEW: http://review.gluster.org/12814 (cli/geo-rep : remove unused code) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Vijay Bellur 2015-12-02 05:19:46 UTC
REVIEW: http://review.gluster.org/12814 (cli/geo-rep : remove unused code) posted (#2) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 3 Vijay Bellur 2015-12-02 15:34:24 UTC
COMMIT: http://review.gluster.org/12814 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 4c6a915811753840b0d1b5685fcaa3e593d9b3cd
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Fri Nov 27 11:18:00 2015 +0530

    cli/geo-rep : remove unused code
    
            Backport of http://review.gluster.org/#/c/12771/
    
    > Change-Id: I8a8e27b4d6c35ea5e57bd0b556fd2c6ab7b496ab
    > BUG: 1285968
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/12771
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Venky Shankar <vshankar@redhat.com>
    
    Change-Id: I8a8e27b4d6c35ea5e57bd0b556fd2c6ab7b496ab
    BUG: 1286517
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12814
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Kaushal 2016-04-19 07:49:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.