This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1285968 - cli/geo-rep : remove unused code
cli/geo-rep : remove unused code
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
All Unspecified
low Severity low
: ---
: ---
Assigned To: Manikandan
: EasyFix, Triaged
: 1285967 (view as bug list)
Depends On:
Blocks: 1286517
  Show dependency treegraph
 
Reported: 2015-11-27 00:41 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1286517 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-11-27 00:41:18 EST
Description of problem:

In cli-rpc-ops.c, gf_cli_gsync_set_cbk(), unused code is there.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-11-27 00:49:10 EST
REVIEW: http://review.gluster.org/12771 (cli/geo-rep : remove unused code) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-11-27 04:44:30 EST
COMMIT: http://review.gluster.org/12771 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 87845356171afcd07f62f46dd81596e4f71e7935
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Fri Nov 27 11:18:00 2015 +0530

    cli/geo-rep : remove unused code
    
    Change-Id: I8a8e27b4d6c35ea5e57bd0b556fd2c6ab7b496ab
    BUG: 1285968
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/12771
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 3 Manikandan 2015-12-01 07:52:44 EST
*** Bug 1285967 has been marked as a duplicate of this bug. ***
Comment 4 Niels de Vos 2016-06-16 09:47:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.