Bug 128654 - Dell Latitude laptop hangs on logout with FC2
Dell Latitude laptop hangs on logout with FC2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 14:29 EDT by Mike Iglesias
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: Fedora Core 4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 16:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Iglesias 2004-07-27 14:29:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
I installed Fedora Core 2 on a Dell Latitude C600 laptop (dual boot
with W2k).  This laptop was previously running RedHat 7.1 and W2k, and
worked fine.

The install went fine, and booted fine.  After finishing the
installation I logged in as root to do some more setup.  When I tried
to log out (click red hat, click log out, click OK), the screen goes
black and the system hangs.  No response to keyboard, mouse, or pings.
 I tried doing this while ssh'd in from another system, and the ssh
session quit working too.  It's a hard hang, as I have to power cycle
the laptop to get it to work again.  W2k works fine, so I doubt it's a
hardware problem.

There is nothing in the logs that give a clue as to what is happening.
This happens if I log in as a regular user instead of root as well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in
2.log out
3.hang
    

Additional info:
Comment 1 Mike Iglesias 2004-07-28 12:11:21 EDT
Here's some additional information:

I changed the runlevel to 3 and booted the laptop.  Logged in, did a
"startx", and logged out.  It dropped me back to the console screen
and was working fine.

So whatever this is has something to do with the system being in
runlevel 5 when I log out.
Comment 2 Mike Iglesias 2004-07-28 20:10:30 EDT
Still more info:

Setting 

AlwaysRestartServer=true

in /etc/X11/gdm/gdm.conf

seems to have cured this problem, at least for now...
Comment 3 Kristian Høgsberg 2004-09-14 21:56:31 EDT
This looks like a duplicate of bug #123424l, could you try to update
to a more recent kernel and see if that fixes the problem?

Thanks.
Comment 4 Mike Iglesias 2004-09-15 12:42:59 EDT
The latest kernel (2.6.8-1.521) did not fix it.  Commenting out the

Load "dri"

in /etc/X11/xorg.conf seems to have helped, in that most of the time I
get the gdm login display when I log out.  If I log out with "Save
Current Setup" checked, none of the windows respond, the cursor will
still move around the screen, but clicking doesn't do anything.  I
have to switch to a console window and manually kill the X process. 
I've seen this last issue on a desktop system running a fully updated
FC2, so it may not have anything to do with the issue I reported
initially.
Comment 5 Marius Andreiana 2005-08-19 16:33:20 EDT
I have a Dell Latitude D600 laptop at work, which works fine with FC4. Video
card is ATI, referenced in bug 123424.

Please try with FC4 and re-open if still not working, FC2 isn't supported anymore.
Comment 6 Mike Iglesias 2005-08-19 16:38:14 EDT
FC4 works fine - I've been running it since it was released.


Note You need to log in before you can comment on or make changes to this bug.