This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286556 - /usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty pattern match.
/usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty p...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1313666 1326079 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 04:02 EST by Marcin Juszkiewicz
Modified: 2016-05-21 22:25 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-1.1.9-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-21 22:25:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Juszkiewicz 2015-11-30 04:02:32 EST
Description of problem:

10:00 root@pinkiepie-rawhide:dnf$ LC_ALL=C LANGUAGE=C LANG=C dnf update  --exclude "systemd*" 
/usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty pattern match.
  return _compile(pattern, flags).split(string, maxsplit)
Last metadata expiration check performed 0:56:08 ago on Mon Nov 30 09:04:28 2015.
Dependencies resolved.
Nothing to do.
Complete!

10:00 root@pinkiepie-rawhide:dnf$ LC_ALL=C LANGUAGE=C LANG=C dnf update  --exclude "systemd.*" 
/usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty pattern match.
  return _compile(pattern, flags).split(string, maxsplit)
Last metadata expiration check performed 0:56:13 ago on Mon Nov 30 09:04:28 2015.
Dependencies resolved.
================================================================================
 Package                   Arch          Version            Repository     Size
================================================================================
Skipping packages with broken dependencies:
 systemd-compat-libs       aarch64       227-6.fc24         rawhide       134 k
 systemd-devel             aarch64       227-6.fc24         rawhide       247 k
 systemd-libs              aarch64       227-6.fc24         rawhide       437 k

Transaction Summary
================================================================================
Skip  3 Packages

Nothing to do.
Complete!
10:00 root@pinkiepi

Version-Release number of selected component (if applicable):

10:00 root@pinkiepie-rawhide:dnf$ dnf --version
1.1.4
  Zainstalowane: dnf-0:1.1.4-1.fc24.noarch o 2015-11-30 08:42
  Zbudowane    : Fedora Project o 2015-11-16 15:19

  Zainstalowane: rpm-0:4.13.0-0.rc1.12.fc24.aarch64 o 2015-11-30 08:42
  Zbudowane    : Fedora Project o 2015-11-24 19:11

How reproducible:

always

Steps to Reproduce:
1. dnf update --exclude "systemd*"

Actual results:

python warning message

Expected results:

no warning message

Additional info:

Probably code needs to be adapted to Python 3.5
Comment 1 dominique 2016-01-13 11:14:25 EST
same problem with my F24 rawhide and dnf.
When I do a :
dnf upgrade --exclude kernel*
I have same warning : 
/usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty pattern match.

Can you fix that ?
Comment 2 Jan Kurik 2016-02-24 09:03:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Igor Gnatenko 2016-04-26 11:48:19 EDT
*** Bug 1313666 has been marked as a duplicate of this bug. ***
Comment 4 Igor Gnatenko 2016-04-26 11:48:43 EDT
*** Bug 1326079 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2016-05-19 07:08:22 EDT
dnf-plugins-core-0.1.21-1.fc24 dnf-1.1.9-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1efd7bc386
Comment 6 Fedora Update System 2016-05-19 07:10:33 EDT
dnf-1.1.9-1.fc23 dnf-plugins-core-0.1.21-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bb69db975e
Comment 7 Fedora Update System 2016-05-20 21:33:11 EDT
dnf-1.1.9-1.fc24, dnf-plugins-core-0.1.21-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1efd7bc386
Comment 8 Fedora Update System 2016-05-20 22:27:28 EDT
dnf-1.1.9-1.fc23, dnf-plugins-core-0.1.21-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bb69db975e
Comment 9 Fedora Update System 2016-05-21 22:24:24 EDT
dnf-1.1.9-1.fc23, dnf-plugins-core-0.1.21-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.