Bug 1313666 - dnf: FutureWarning with --exclude=name
dnf: FutureWarning with --exclude=name
Status: CLOSED DUPLICATE of bug 1286556
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 02:38 EST by Lukas Slebodnik
Modified: 2016-04-26 11:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 11:48:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2016-03-02 02:38:55 EST
Description of problem:
Future warning is printed if dnf is called with argument --exclude


Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc24.noarch
python3-3.5.1-6.fc24.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. dnf update --exclude=dummy_name
# it can be also name of real package

Actual results:
/usr/lib64/python3.5/re.py:203: FutureWarning: split() requires a non-empty pattern match.
  return _compile(pattern, flags).split(string, maxsplit)

Expected results:
There isn't any warning.
Comment 1 Honza Silhan 2016-03-14 08:32:21 EDT
Thanks for the report.
Comment 2 Parag Nemade 2016-04-12 00:17:38 EDT
*** Bug 1326079 has been marked as a duplicate of this bug. ***
Comment 3 Igor Gnatenko 2016-04-26 11:48:19 EDT

*** This bug has been marked as a duplicate of bug 1286556 ***

Note You need to log in before you can comment on or make changes to this bug.