Bug 1286558 - engine-setup should not depend on yum groups
engine-setup should not depend on yum groups
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Setup.Core (Show other bugs)
3.6.1
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Sandro Bonazzola
Gonza
: CodeChange
: 1084489 (view as bug list)
Depends On:
Blocks: 1286660
  Show dependency treegraph
 
Reported: 2015-11-30 04:07 EST by Yedidyah Bar David
Modified: 2016-10-31 05:03 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: engine-setup relied on a specific yum group to define a set of additional packages to be updated. Consequence: If such a group was not available for any reason, these additional packages were not updated. Fix: engine-setup was changed to not rely on such a group and instead have this list hard-coded in it. This list can be overridden by an answer file if needed. Result: The list of packages to upgrade is independent of the yum repository management so they are always updated.
Story Points: ---
Clone Of:
: 1286660 (view as bug list)
Environment:
Last Closed: 2016-02-18 06:07:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
sherold: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49105 master MERGED packaging: setup: Require latest otopi Never
oVirt gerrit 49106 master MERGED packaging: setup: Install/Update additional packages 2015-12-23 05:16 EST
oVirt gerrit 50966 ovirt-engine-3.6 MERGED packaging: setup: Install/Update additional packages 2015-12-23 12:58 EST
oVirt gerrit 50967 ovirt-engine-3.6.2 MERGED packaging: setup: Install/Update additional packages 2015-12-23 13:01 EST
oVirt gerrit 65889 master MERGED packaging: setup: Remove engine yum group 2016-11-10 15:21 EST

  None (edit)
Description Yedidyah Bar David 2015-11-30 04:07:03 EST
Description of problem:

engine-setup currently depends on yum groups ('ovirt-engine-X.Y', 'rhevmXY' in rhevm) for installing/updating extra packages.

This does not work well upstream for some time now (since 3.5.0 was released or so) and so we do not create there yum groups.

Downstream it requires quite a lot of maintenance, having to create such a group and maintain it per release, in various different environments (CI, QE production), is often forgotten.

We should drop this functionality, stop creating these yum groups, and instead using the existing functionality that allows doing that by adding lists of packages to be installed/updated to osetupcons.RPMDistroEnv.PACKAGES_UPGRADE_LIST .

Since we do not have this group in 3.6 currently (not in upstream which is already GA, nor in downstream CI), I propose to accept this bug for 3.6. Patches to add the relevant packages were prepared, and we can drop the functionality later (in 4.0).
Comment 1 Yaniv Lavi (Dary) 2015-12-02 16:14:07 EST
Needs to be discussed in scrub, un-approving for now.
Comment 2 Yedidyah Bar David 2016-01-11 03:22:50 EST
setting requires_doc_text to '-' because we do not use it upstream, and downstream we have bug 1286660, not need to have both.
Comment 3 Lukas Svaty 2016-01-21 10:04:54 EST
as sanity tests with yum passed on this codechange moving to verify
tested with rhevm-3.6.2.6-0.1.el6.noarch
Comment 4 Yedidyah Bar David 2016-01-24 05:29:28 EST
*** Bug 1084489 has been marked as a duplicate of this bug. ***
Comment 5 Gonza 2016-01-27 11:06:31 EST
Verified with upgrade from:
ovirt-engine-3.5.6.2-1.el6.noarch
to:
ovirt-engine-3.6.2.6-1.el6.noarch

Downgraded Otopi in between upgrades:
yum downgrade ./builds/3.6/3.6.0-14/el6/noarch/otopi-1.4.0-0.0.6.master.el6ev.noarch.rpm ./builds/3.6/3.6.0-14/el6/noarch/otopi-java-1.4.0-0.0.6.master.el6ev.noarch.rpm

Upgrade completed successfully with the following:
...
Setup has found updates for some packages:
PACKAGE: [install] ebay-cors-filter-1.0.1-0.1.ovirt.el6.noarch
PACKAGE: [updated] ovirt-engine-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-backend-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-backend-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-cli-3.5.0.6-1.el6.noarch
PACKAGE: [update] ovirt-engine-cli-3.6.0.2-1.el6.noarch
PACKAGE: [updated] ovirt-engine-dbscripts-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-dbscripts-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-extensions-api-impl-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-extensions-api-impl-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-restapi-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-restapi-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-sdk-python-3.5.6.0-1.el6.noarch
PACKAGE: [update] ovirt-engine-sdk-python-3.6.2.1-1.el6.noarch
PACKAGE: [install] ovirt-engine-setup-plugin-vmconsole-proxy-helper-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-tools-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-tools-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-userportal-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-userportal-3.6.2.6-1.el6.noarch
PACKAGE: [install] ovirt-engine-vmconsole-proxy-helper-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-webadmin-portal-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-webadmin-portal-3.6.2.6-1.el6.noarch
PACKAGE: [updated] ovirt-engine-websocket-proxy-3.5.6.2-1.el6.noarch
PACKAGE: [update] ovirt-engine-websocket-proxy-3.6.2.6-1.el6.noarch
PACKAGE: [install] ovirt-engine-wildfly-8.2.1-1.el6.x86_64
PACKAGE: [install] ovirt-engine-wildfly-overlay-8.0.4-1.el6.noarch
PACKAGE: [updated] ovirt-host-deploy-1.3.2-1.el6.noarch
PACKAGE: [update] ovirt-host-deploy-1.4.1-1.el6.noarch
PACKAGE: [updated] ovirt-host-deploy-java-1.3.2-1.el6.noarch
PACKAGE: [update] ovirt-host-deploy-java-1.4.1-1.el6.noarch
PACKAGE: [updated] ovirt-image-uploader-3.5.1-1.el6.noarch
PACKAGE: [update] ovirt-image-uploader-3.6.0-1.el6.noarch
PACKAGE: [updated] ovirt-iso-uploader-3.5.2-1.el6.noarch
PACKAGE: [update] ovirt-iso-uploader-3.6.0-1.el6.noarch
PACKAGE: [install] ovirt-log-collector-3.6.0-1.el6.noarch
PACKAGE: [install] ovirt-vmconsole-1.0.0-1.el6.noarch
PACKAGE: [install] ovirt-vmconsole-proxy-1.0.0-1.el6.noarch
PACKAGE: [install] slf4j-1.7.7-1.el6.noarch
PACKAGE: [updated] vdsm-jsonrpc-java-1.0.15-1.el6.noarch
PACKAGE: [update] vdsm-jsonrpc-java-1.1.7-1.el6.noarch
...

Note You need to log in before you can comment on or make changes to this bug.