Bug 1286660 - engine-setup should not depend on yum groups
engine-setup should not depend on yum groups
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-setup-plugins (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity medium
: ovirt-3.6.2
: 3.6.0
Assigned To: Yedidyah Bar David
Gonza
:
Depends On: 1286558
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 07:36 EST by Sandro Bonazzola
Modified: 2016-03-09 14:57 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, engine-setup relied on a specific yum group to define a set of additional packages to be updated and if the group was not available for any reason these additional packages were not updated. Now, engine-setup has been changed and no longer relies on the specific yum group. Instead engine-setup now has this list hard-coded into it. The list of packages to upgrade is now independent of the yum repository management so that they remain updated.
Story Points: ---
Clone Of: 1286558
Environment:
Last Closed: 2016-03-09 14:57:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2015-11-30 07:36:14 EST
+++ This bug was initially created as a clone of Bug #1286558 +++

Description of problem:

engine-setup currently depends on yum groups ('ovirt-engine-X.Y', 'rhevmXY' in rhevm) for installing/updating extra packages.

This does not work well upstream for some time now (since 3.5.0 was released or so) and so we do not create there yum groups.

Downstream it requires quite a lot of maintenance, having to create such a group and maintain it per release, in various different environments (CI, QE production), is often forgotten.

We should drop this functionality, stop creating these yum groups, and instead using the existing functionality that allows doing that by adding lists of packages to be installed/updated to osetupcons.RPMDistroEnv.PACKAGES_UPGRADE_LIST .

Since we do not have this group in 3.6 currently (not in upstream which is already GA, nor in downstream CI), I propose to accept this bug for 3.6. Patches to add the relevant packages were prepared, and we can drop the functionality later (in 4.0).
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-01 04:47:54 EST
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.
Comment 4 Yedidyah Bar David 2015-12-23 15:20:22 EST
Changing the component because the fix is in a different package
Comment 7 Lukas Svaty 2016-01-21 10:05:05 EST
as sanity tests with yum passed on this codechange moving to verify
tested with rhevm-3.6.2.6-0.1.el6.noarch
Comment 11 Gonza 2016-01-27 06:27:42 EST
Verified with upgrade from:
rhevm-3.6.1-0.2.el6.noarch
to:
rhevm-3.6.2.6-0.1.el6.noarch

Downgraded Otopi in the between upgrades:
yum downgrade http://bob.eng.lab.tlv.redhat.com/builds/3.6/3.6.0-14/el6/noarch/otopi-1.4.0-0.0.6.master.el6ev.noarch.rpm http://bob.eng.lab.tlv.redhat.com/builds/3.6/3.6.0-14/el6/noarch/otopi-java-1.4.0-0.0.6.master.el6ev.noarch.rpm

Upgrade completed successfully with the following:
...
Setup has found updates for some packages:
PACKAGE: [updated] ovirt-engine-extension-aaa-jdbc-1.0.3-1.el6ev.noarch
PACKAGE: [update] ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
PACKAGE: [updated] rhevm-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-backend-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-backend-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-branding-rhev-3.6.0-2.el6ev.noarch
PACKAGE: [update] rhevm-branding-rhev-3.6.0-3.el6ev.noarch
PACKAGE: [updated] rhevm-dbscripts-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-dbscripts-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-extensions-api-impl-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-extensions-api-impl-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-restapi-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-restapi-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-tools-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-tools-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-userportal-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-userportal-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-vmconsole-proxy-helper-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-vmconsole-proxy-helper-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-webadmin-portal-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-webadmin-portal-3.6.2.6-0.1.el6.noarch
PACKAGE: [updated] rhevm-websocket-proxy-3.6.1-0.2.el6.noarch
PACKAGE: [update] rhevm-websocket-proxy-3.6.2.6-0.1.el6.noarch
...
Comment 12 Yedidyah Bar David 2016-03-06 01:40:00 EST
Decided to drop the part about the answer file from the doc text, as it's not intended for direct end user manipulation, and not documented elsewhere.
Comment 14 errata-xmlrpc 2016-03-09 14:57:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0395.html

Note You need to log in before you can comment on or make changes to this bug.