Bug 1286565 - Warn about non-replica 3 gluster volume instead of failing connection to server
Warn about non-replica 3 gluster volume instead of failing connection to server
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Ala Hino
Aharon Canan
:
: 1287211 (view as bug list)
Depends On:
Blocks: 1291705
  Show dependency treegraph
 
Reported: 2015-11-30 04:17 EST by Ala Hino
Modified: 2016-02-18 06:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:00:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50119 master MERGED gluster: Warn instead of failing for unsupported gluster replica modes Never
oVirt gerrit 50258 ovirt-3.6 MERGED gluster: Warn instead of failing for unsupported gluster replica modes Never

  None (edit)
Description Ala Hino 2015-11-30 04:17:11 EST
Description of problem:
In oVirt 3.5, admins were able to create gluster sds with any volume type. However, in 3.6 and because we recommend using replica 3 volumes, we enforced using only replica 3 volumes. Enforcing means not allowing admins to create non-replica 3 volumes (although admins were still able to configure supported replicas). 
This enforcement introduced major issue when upgrading deployments using non-replica 3 volumes. Actually, 3.5 deployments using non-replica 3 volumes stopped working when upgraded to 3.6.

We would like to have the following behavior:
1. Allow creating sds with any replica count
2. If replica count is not 3, display an alert to the admin
Comment 1 Allon Mureinik 2015-12-02 05:36:35 EST
*** Bug 1287211 has been marked as a duplicate of this bug. ***
Comment 2 Nir Soffer 2015-12-08 15:49:44 EST
We should warn also when connecting to existing gluster storage domain, not only when creating a new gluster storage domain.
Comment 3 Ala Hino 2015-12-15 08:30:16 EST
The work related to alerts will be tracked in following bug:

https://bugzilla.redhat.com/1291705
Comment 4 Ala Hino 2015-12-17 11:40:55 EST
Please note doc-text for this bug is provided here: https://bugzilla.redhat.com/1123052
Comment 5 Sandro Bonazzola 2015-12-23 08:40:22 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 6 Ala Hino 2016-01-05 11:20:20 EST
For clarification:
Please note that log message is presented only when replica count is not supported as defined in "allowed_replica_counts" config value. By default, replica 1 and 3 are supported.
In addition, the log message appears in vdsm log. Look for:
"Unsupported replica count" 
or
"please upgrade volume to replica 3"
Comment 7 Ala Hino 2016-01-05 11:23:40 EST
(In reply to Ala Hino from comment #6)
> For clarification:
> Please note that log message is presented only when replica count is not
> supported as defined in "allowed_replica_counts" config value. By default,
> replica 1 and 3 are supported.
> In addition, the log message appears in vdsm log. Look for:
> "Unsupported replica count" 
> or
> "please upgrade volume to replica 3"

Displaying an alert to the admin is not in the scope if this bug, see bug 1291705
Comment 8 Aharon Canan 2016-01-05 11:27:56 EST
Verified 

vdsm-4.17.15-0.el7ev.noarch
rhevm-3.6.2-0.1.el6.noarch

from vdsm.log
=============
jsonrpc.Executor/4::WARNING::2016-01-05 18:23:25,517::storageServer::350::Storage.StorageServer.MountConnection::(validate) Unsupported replica count (2) for volume u'acanan_replica5', please upgrade volume to replica 3

Note You need to log in before you can comment on or make changes to this bug.