Bug 1287211 - gluster replica count greater then 3
gluster replica count greater then 3
Status: CLOSED DUPLICATE of bug 1286565
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.0
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-3.6.2
: 4.17.12
Assigned To: Ala Hino
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 13:52 EST by matt.deboer
Modified: 2016-02-10 14:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 05:36:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description matt.deboer 2015-12-01 13:52:01 EST
Description of problem:
I cannot set up gluster replica counts greater then 3 in ovirt. They can be done from the command line but then if a server goes offline, when it comes back it refuses to connect to the storage pool unless the replica count is 3

Is there a reason for only allowing 3?  5 i think should be allowed at least because you can still maintain quorum even if 2 hosts go down.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Allon Mureinik 2015-12-02 05:36:35 EST
Matt, thanks for this report!

This was a design decision made for oVirt 3.6.0, which, given the feedback from the community, we are regretting, and intend to undo in the upcoming release.
See bug 1286565 for details.

*** This bug has been marked as a duplicate of bug 1286565 ***

Note You need to log in before you can comment on or make changes to this bug.