Bug 1286601 - vol quota enable fails when transport.socket.bind-address is set in glusterd
vol quota enable fails when transport.socket.bind-address is set in glusterd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed Ashiq
:
Depends On: 1277105 1286605
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 05:05 EST by Mohamed Ashiq
Modified: 2016-04-19 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277105
Environment:
Last Closed: 2016-04-19 03:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-11-30 05:05:22 EST
+++ This bug was initially created as a clone of Bug #1277105 +++

Description of problem:
When you bind glusterd to a specific IP, shd operates correctly but the 'vol replace-brick' command attempts to contact glusterd on 127.0.0.1 and fails.


Version-Release number of selected component (if applicable):
glusterfs 3.7.x (and prior releases?)

How reproducible:
Every time! I noticed this in a test environment I'm using for containers, where I bind glusterd host IP.

Steps to Reproduce:
1.use transport.socket.bind-address to bind glusterd to a specific IP on each host
2.issue 'gluster volume quota <VOLNAME> enable'

Actual results:
command fails with error "quota: Could not start quota auxiliary mount"

Expected results:
quota should create auxiliary mount and should be enabled even 'transport.socket.bind-address' is set. 

Additional info:
The issue has been discussed with Ravi (ravishankar@redhat.com) and Humble (hchiramm@redhat.com) and identified as localhost being hardcoded.

--- Additional comment from Vijay Bellur on 2015-11-02 06:33:12 EST ---

REVIEW: http://review.gluster.org/12489 (vol quota fails when transport.socket.bind-address is set in glusterd) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 07:01:12 EST ---

REVIEW: http://review.gluster.org/12489 (quota,qlusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#2) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

--- Additional comment from Vijay Bellur on 2015-11-02 07:39:56 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#3) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 23:38:23 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-03 01:34:47 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-19 10:03:24 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#10) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-20 00:46:02 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#11) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-27 00:09:02 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#12) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-30 03:09:40 EST ---

COMMIT: http://review.gluster.org/12489 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 0441e50959e9305c5bc4d0af0576593f8755730e
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Mon Nov 9 22:09:34 2015 +0530

    quota: vol quota fails when transport.socket.bind-address is set in glusterd
    
    When glusterd is binded to specific IP quota fails, since the server is
    hardcoded to localhost. IP can be assigned in the glusterd part of quota,
    but IP is not populated in cli part. So Quota makes use of glusterfsd's unix
    domain socket transport type.
    
    Change-Id: Ib03332cc203795456ee6087017cea08eed3d7417
    BUG: 1277105
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12489
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 1 Vijay Bellur 2015-11-30 05:30:58 EST
REVIEW: http://review.gluster.org/12819 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#1) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-12-04 06:20:56 EST
REVIEW: http://review.gluster.org/12819 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#2) for review on release-3.7 by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Vijay Bellur 2015-12-07 23:23:47 EST
COMMIT: http://review.gluster.org/12819 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit e1a9914fb318cbdd2bb8f36881e8f5f0b45ce76c
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Mon Nov 9 22:09:34 2015 +0530

    quota: vol quota fails when transport.socket.bind-address is set in glusterd
    
    When glusterd is binded to specific IP quota fails, since the server is
    hardcoded to localhost. IP can be assigned in the glusterd part of quota,
    but IP is not populated in cli part. So Quota makes use of glusterfsd's unix
    domain socket transport type.
    
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    
    >Change-Id: Ib03332cc203795456ee6087017cea08eed3d7417
    >BUG: 1277105
    >Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    >Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    >Reviewed-on: http://review.gluster.org/12489
    >Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I0fb2b5aff664101135c4f40d47517c1b1759b0af
    BUG: 1286601
    Reviewed-on: http://review.gluster.org/12819
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Kaushal 2016-04-19 03:49:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.