This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1286605 - vol quota enable fails when transport.socket.bind-address is set in glusterd
vol quota enable fails when transport.socket.bind-address is set in glusterd
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Mohamed Ashiq
Anil Shah
: ZStream
Depends On: 1277105
Blocks: 1260783 1286601
  Show dependency treegraph
 
Reported: 2015-11-30 05:11 EST by Mohamed Ashiq
Modified: 2016-09-17 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-9
Doc Type: Bug Fix
Doc Text:
Previously, when transport.socket.bind-address was set in glusterd, quota auxiliary mount and glusterfsd request for volfile failed since the IP is hard-coded to the localhost. With this fix, glusterfsd unix volfile-server-transport type is used to fetch the volfile. The quota auxiliary mount does not fail even when glusterd is bound to a specific IP.
Story Points: ---
Clone Of: 1277105
Environment:
Last Closed: 2016-03-01 00:59:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohamed Ashiq 2015-11-30 05:11:02 EST
+++ This bug was initially created as a clone of Bug #1277105 +++

Description of problem:
When you bind glusterd to a specific IP, shd operates correctly but the 'vol replace-brick' command attempts to contact glusterd on 127.0.0.1 and fails.


Version-Release number of selected component (if applicable):
glusterfs 3.7.x (and prior releases?)

How reproducible:
Every time! I noticed this in a test environment I'm using for containers, where I bind glusterd host IP.

Steps to Reproduce:
1.use transport.socket.bind-address to bind glusterd to a specific IP on each host
2.issue 'gluster volume quota <VOLNAME> enable'

Actual results:
command fails with error "quota: Could not start quota auxiliary mount"

Expected results:
quota should create auxiliary mount and should be enabled even 'transport.socket.bind-address' is set. 

Additional info:
The issue has been discussed with Ravi (ravishankar@redhat.com) and Humble (hchiramm@redhat.com) and identified as localhost being hardcoded.

--- Additional comment from Vijay Bellur on 2015-11-02 06:33:12 EST ---

REVIEW: http://review.gluster.org/12489 (vol quota fails when transport.socket.bind-address is set in glusterd) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 07:01:12 EST ---

REVIEW: http://review.gluster.org/12489 (quota,qlusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#2) for review on master by Humble Devassy Chirammal (humble.devassy@gmail.com)

--- Additional comment from Vijay Bellur on 2015-11-02 07:39:56 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#3) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 23:38:23 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-03 01:34:47 EST ---

REVIEW: http://review.gluster.org/12489 (quota,glusterd: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-19 10:03:24 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#10) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-20 00:46:02 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#11) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-27 00:09:02 EST ---

REVIEW: http://review.gluster.org/12489 (quota: vol quota fails when transport.socket.bind-address is set in glusterd) posted (#12) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-30 03:09:40 EST ---

COMMIT: http://review.gluster.org/12489 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 0441e50959e9305c5bc4d0af0576593f8755730e
Author: Mohamed Ashiq <mliyazud@redhat.com>
Date:   Mon Nov 9 22:09:34 2015 +0530

    quota: vol quota fails when transport.socket.bind-address is set in glusterd
    
    When glusterd is binded to specific IP quota fails, since the server is
    hardcoded to localhost. IP can be assigned in the glusterd part of quota,
    but IP is not populated in cli part. So Quota makes use of glusterfsd's unix
    domain socket transport type.
    
    Change-Id: Ib03332cc203795456ee6087017cea08eed3d7417
    BUG: 1277105
    Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com>
    Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com>
    Reviewed-on: http://review.gluster.org/12489
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 2 Mohamed Ashiq 2015-12-02 00:27:57 EST
patch :

https://code.engineering.redhat.com/gerrit/62593
Comment 4 Anil Shah 2015-12-18 09:46:29 EST
bug verified on build glusterfs-server-3.7.5-12.el7rhgs.x86_64
Comment 6 errata-xmlrpc 2016-03-01 00:59:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.