Bug 128664 - Crashes when canceling activation of an interface as non-root
Crashes when canceling activation of an interface as non-root
Status: CLOSED DUPLICATE of bug 103421
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-27 15:11 EDT by Sebastian Jester
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback from redhat-control-network (2.00 KB, text/plain)
2004-07-27 15:12 EDT, Sebastian Jester
no flags Details

  None (edit)
Description Sebastian Jester 2004-07-27 15:11:34 EDT
From Bugzilla Helper:
User-Agent: Opera/7.53 (X11; Linux i686; U)  [en]

Description of problem:
I have configured all my devices so that they can be activated by all 
users. Logged in as non-root, I launch redhat-control-network and hit 
the 'activate' button for one of the devices. When I press 'cancel' 
in the "Activating network device XXX, please wait..." dialog box, I 
get another dialog window "an unhandled exception occurred". The 
crash dump is in the attachment. This doesn't happen when I run 
redhat-control-network as root.

In other words, canceling an activation only works as expected when I 
am root.

Version-Release number of selected component (if applicable):
1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1. start redhat-control-network
2. activate any device
3. press 'cancel' in "activating device, please wait" dialog box
    

Actual Results:   I get another dialog window "an unhandled exception 
occurred"

Expected Results:  Activation is cancelled and dialog box is closed.

Additional info:
Comment 1 Sebastian Jester 2004-07-27 15:12:48 EDT
Created attachment 102237 [details]
Traceback from redhat-control-network
Comment 2 Harald Hoyer 2004-07-28 03:20:29 EDT

*** This bug has been marked as a duplicate of 103421 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.