Bug 1286690 - Orchestration template edit and remove button would remain incorrectly disabled in certain scenarios
Orchestration template edit and remove button would remain incorrectly disabl...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Milan Zazrivec
Niyaz Akhtar Ansari
service:provision:stack
:
Depends On:
Blocks: 1288103
  Show dependency treegraph
 
Reported: 2015-11-30 09:00 EST by Milan Zazrivec
Modified: 2016-06-29 11:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288103 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:13:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2015-11-30 09:00:21 EST
Description of problem:
Buttons for orchestration template editing and removal can remain disabled permanently
in certain situations


Version-Release number of selected component (if applicable):
CFME 5.5

How reproducible:
Always

Steps to Reproduce:
1. Make sure your CFME instance contains orchestration template that is read only (i.e. is
   connected to an orchestration stack)
2. Make sure your CFME instance contains orchestration template that is not read only
   (you can for example create one from scratch)
3. Navigate to Services -> Catalogs -> Orchestration Templates
4. Click on a template that *is not* read only and see that under 'Configuration' button,
   the edit and removal buttons are active (this is correct)
5. Click on a template that *is* read only and see that under 'Configuration' button,
   the edit and removal buttons are disabled (this is also correct)
6. Click on a template that *is not* read only and see that under 'Configuration' button,
   the edit and removal buttons are disabled (although should be enabled).

Actual results:
As described above.

Expected results:
Edit and removal buttons should be disabled for read only templates and disabled for templates
that are not read only.

Additional info:
N/A
Comment 1 Milan Zazrivec 2015-12-01 07:50:02 EST
https://github.com/ManageIQ/manageiq/pull/5658
Comment 2 Milan Zazrivec 2015-12-01 11:11:16 EST
This bug definitely needs to be addressed for CFME 5.5 (as an errata
or part of 5.5 update or whatever) or customers, who will do the steps
outlined above will have those edit & remove buttons disabled everywhere
forever and ever (unless they reboot their appliance).
Comment 3 CFME Bot 2015-12-02 14:45:36 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b44957f497f3cb452728d267f73db1522e838124

commit b44957f497f3cb452728d267f73db1522e838124
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Nov 30 14:36:31 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Tue Dec 1 13:48:56 2015 +0100

    Fix rendering of edit and remove buttons for orchestration templates
    
    Previously, when selecting a read-write OT, then selecting a read-only
    OT and then selecting back the read-write OT would incorrectly disable
    edit and removal buttons for the read-write OT.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1286690

 app/helpers/application_helper/toolbar_builder.rb   |  6 +++---
 .../application_helper/toolbar_builder_spec.rb      | 21 +++++++++++++++++++++
 2 files changed, 24 insertions(+), 3 deletions(-)
Comment 4 Niyaz Akhtar Ansari 2016-04-19 08:24:52 EDT
Edit and removal buttons are disabled for read only templates and enabled for templates that are not read only

Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 6 errata-xmlrpc 2016-06-29 11:13:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.