Bug 1288103 - Orchestration template edit and remove button would remain incorrectly disabled in certain scenarios
Orchestration template edit and remove button would remain incorrectly disabl...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Shveta
Shveta
: ZStream
Depends On: 1286690
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 09:27 EST by John Prause
Modified: 2016-04-13 14:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286690
Environment:
Last Closed: 2016-04-13 14:39:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
enabled buttons (167.79 KB, image/png)
2016-03-28 18:59 EDT, Shveta
no flags Details

  None (edit)
Description John Prause 2015-12-03 09:27:30 EST
+++ This bug was initially created as a clone of Bug #1286690 +++

Description of problem:
Buttons for orchestration template editing and removal can remain disabled permanently
in certain situations


Version-Release number of selected component (if applicable):
CFME 5.5

How reproducible:
Always

Steps to Reproduce:
1. Make sure your CFME instance contains orchestration template that is read only (i.e. is
   connected to an orchestration stack)
2. Make sure your CFME instance contains orchestration template that is not read only
   (you can for example create one from scratch)
3. Navigate to Services -> Catalogs -> Orchestration Templates
4. Click on a template that *is not* read only and see that under 'Configuration' button,
   the edit and removal buttons are active (this is correct)
5. Click on a template that *is* read only and see that under 'Configuration' button,
   the edit and removal buttons are disabled (this is also correct)
6. Click on a template that *is not* read only and see that under 'Configuration' button,
   the edit and removal buttons are disabled (although should be enabled).

Actual results:
As described above.

Expected results:
Edit and removal buttons should be disabled for read only templates and disabled for templates
that are not read only.

Additional info:
N/A

--- Additional comment from Milan Zazrivec on 2015-12-01 07:50:02 EST ---

https://github.com/ManageIQ/manageiq/pull/5658

--- Additional comment from Milan Zazrivec on 2015-12-01 11:11:16 EST ---

This bug definitely needs to be addressed for CFME 5.5 (as an errata
or part of 5.5 update or whatever) or customers, who will do the steps
outlined above will have those edit & remove buttons disabled everywhere
forever and ever (unless they reboot their appliance).

--- Additional comment from CFME Bot on 2015-12-02 14:45:36 EST ---

New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b44957f497f3cb452728d267f73db1522e838124

commit b44957f497f3cb452728d267f73db1522e838124
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Nov 30 14:36:31 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Tue Dec 1 13:48:56 2015 +0100

    Fix rendering of edit and remove buttons for orchestration templates
    
    Previously, when selecting a read-write OT, then selecting a read-only
    OT and then selecting back the read-write OT would incorrectly disable
    edit and removal buttons for the read-write OT.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1286690

 app/helpers/application_helper/toolbar_builder.rb   |  6 +++---
 .../application_helper/toolbar_builder_spec.rb      | 21 +++++++++++++++++++++
 2 files changed, 24 insertions(+), 3 deletions(-)
Comment 3 CFME Bot 2016-02-25 10:16:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d5643937c3e2bffc694a483aaee8e7e6e5c64fb2

commit d5643937c3e2bffc694a483aaee8e7e6e5c64fb2
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Mon Nov 30 14:36:31 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Thu Feb 25 11:40:56 2016 +0100

    Fix rendering of edit and remove buttons for orchestration templates
    
    Previously, when selecting a read-write OT, then selecting a read-only
    OT and then selecting back the read-write OT would incorrectly disable
    edit and removal buttons for the read-write OT.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288103
    (cherry picked from commit b44957f497f3cb452728d267f73db1522e838124)

 app/helpers/application_helper/toolbar_builder.rb  |  6 ++---
 .../application_helper/toolbar_builder_spec.rb     | 26 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 3 deletions(-)
Comment 4 CFME Bot 2016-02-25 10:16:41 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4dff6f6f2695f31f1d6924c254feba84c19a5813

commit 4dff6f6f2695f31f1d6924c254feba84c19a5813
Merge: 64a186f d564393
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Feb 25 10:13:17 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Feb 25 10:13:17 2016 -0500

    Merge branch 'fix_ot_edit_and_remove_buttons' into '5.5.z'
    
    Fix rendering of edit and remove buttons for orchestration templates
    
    Previously, when selecting a read-write OT, then selecting a read-only
    OT and then selecting back the read-write OT would incorrectly disable
    edit and removal buttons for the read-write OT.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288103
    (cherry picked from commit b44957f497f3cb452728d267f73db1522e838124)
    
    See merge request !809

 app/helpers/application_helper/toolbar_builder.rb  |  6 ++---
 .../application_helper/toolbar_builder_spec.rb     | 26 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 3 deletions(-)
Comment 6 Shveta 2016-03-28 18:59 EDT
Created attachment 1141035 [details]
enabled buttons

Verified in 5.5.3.2.20160318152106_92d2d67
Comment 8 errata-xmlrpc 2016-04-13 14:39:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.