Bug 1286937 - EL5 ovirt-guest-agent does not report Guest OS Information
EL5 ovirt-guest-agent does not report Guest OS Information
Status: CLOSED CURRENTRELEASE
Product: ovirt-guest-agent
Classification: oVirt
Component: Core (Show other bugs)
---
All Linux
high Severity medium (vote)
: ovirt-3.6.2
: 1.0.11-4
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
:
: 1286847 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 02:15 EST by Vinzenz Feenstra [evilissimo]
Modified: 2016-02-18 06:22 EST (History)
4 users (show)

See Also:
Fixed In Version: rhevm-guest-agent-1.0.11-4.el5 / EPEL: ovirt-guest-agent-1.0.11-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:22:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vfeenstr: ovirt‑3.6.z?
vfeenstr: planning_ack?
michal.skrivanek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49485 master MERGED Fix osinfo for el5 Never
oVirt gerrit 49667 ovirt-3.6 MERGED Fix osinfo for el5 Never

  None (edit)
Description Vinzenz Feenstra [evilissimo] 2015-12-01 02:15:47 EST
Description of problem:

The operating system reporting does not work on CentOS5/RHEL5 due to an unhandled AttributeError exception

Version-Release number of selected component (if applicable):
ovirt-guest-agent-1.0.11-2

How reproducible:
Always

Steps to Reproduce:
1. install on CentOS5/RHEL5 ovirt-guest-agent-1.0.11-2
2. start the ovirt-guest-agent service
3. No operating system information is reported in the WebAdmin UI under the Guest Info tab

Actual results:
No operating system information reported

Expected results:
Operating system information reported
Comment 1 Red Hat Bugzilla Rules Engine 2015-12-01 02:25:53 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Tomas Jelinek 2015-12-16 04:22:10 EST
*** Bug 1286847 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Belka 2016-02-04 10:07:29 EST
ok, 'rhevm-guest-agent-1.0.11-4.el5',

guestOsInfo = {'kernel': '2.6.18-408.el5', 'arch': 'x86_64', 'version': '5.11', 'distribution': 'Red Hat Enterprise Linux Server', 'type': 'linux', 'codename': 'Tikanga'}

Note You need to log in before you can comment on or make changes to this bug.