Bug 1286965 - Do not install wpa_supplicant.service as executable
Do not install wpa_supplicant.service as executable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: wpa_supplicant (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Lubomir Rintel
Ken Benoit
: Reopened
: 1285098 1301182 1311547 (view as bug list)
Depends On:
Blocks: 1203710 1301628 1313485
  Show dependency treegraph
 
Reported: 2015-12-01 04:06 EST by Jirka Klimes
Modified: 2017-10-06 14:04 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The wpa_supplicant.service was needlessly marked executable causing the systemd service manager to emit warning messages. The executable bits have been removed. (BZ#1286965)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:14:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mleitner: needinfo-


Attachments (Terms of Use)
[PATCH] remove executable bits from wpa_supplicant.service (1.59 KB, patch)
2015-12-01 04:14 EST, Jirka Klimes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2080483 None None None 2016-01-20 09:17 EST

  None (edit)
Description Jirka Klimes 2015-12-01 04:06:40 EST
wpa_supplicant installs systemd service file as executable. That triggers systemd complain:
"systemd: Configuration file /usr/lib/systemd/system/wpa_supplicant.service is marked executable. Please remove executable permission bits. Proceeding anyway."

Let's remove the executable bits.

Notes:
* The bug has been fixed in fedora bug 803980.
* A customer mentioned this warning (among other things) in bug 1286576.
Comment 1 Jirka Klimes 2015-12-01 04:14 EST
Created attachment 1100778 [details]
[PATCH] remove executable bits from wpa_supplicant.service

Patch for RHEL 7 dist-git.
Comment 3 Beniamino Galvani 2015-12-01 05:58:12 EST
LGTM
Comment 4 Dan Williams 2015-12-04 19:15:54 EST
LGTM
Comment 12 Jennifer Scalf 2016-02-17 12:07:32 EST
*** Bug 1301182 has been marked as a duplicate of this bug. ***
Comment 13 Lubomir Rintel 2016-03-17 05:09:57 EDT
*** Bug 1311547 has been marked as a duplicate of this bug. ***
Comment 14 Ken Benoit 2016-05-24 14:08:20 EDT
Installed RHEL-7.3-20160523.n.0 x86_64 and verified that wpa_supplicant.service is no longer showing the executable permissions.

# ls -l /usr/lib/systemd/system/wpa_supplicant.service
-rw-r--r--. 1 root root 365 Mar 21 11:22 /usr/lib/systemd/system/wpa_supplicant.service

Marking as verified.
Comment 17 errata-xmlrpc 2016-11-03 18:14:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2144.html
Comment 18 Lubomir Rintel 2016-11-11 13:06:11 EST
*** Bug 1285098 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.