Bug 1286974 - Without detach tier commit, status changes back to tier migration
Without detach tier commit, status changes back to tier migration
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Reopened, Triaged
Depends On: 1284387
Blocks: 1289898
  Show dependency treegraph
 
Reported: 2015-12-01 04:29 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284387
: 1289898 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-01 05:49:30 EST
REVIEW: http://review.gluster.org/12833 (tier/glusterd: Check before starting tier daemon during volume start) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-07 01:52:06 EST
REVIEW: http://review.gluster.org/12833 (tier/glusterd: Check before starting tier daemon during volume start) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 02:17:02 EST
COMMIT: http://review.gluster.org/12833 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 28da53e26e88f23f8917810ce0177f2628aa7e9a
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 1 09:11:01 2015 +0000

    tier/glusterd: Check before starting tier daemon during volume start
    
    We start tier daemon when volume is started without looking into the
    previous status. The problem with that if detach-tier is started
    and then volume force start is actually starting tier daemon.
    
    This is also fixes a problem where tier daemon is not starting
    after detach stop.
    
    Change-Id: I15b56a711e12f0e24f5ab123561258bd448621f7
    BUG: 1286974
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12833
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Vijay Bellur 2015-12-09 05:03:25 EST
REVIEW: http://review.gluster.org/12921 (tier/glusterd: Check before starting tier daemon during volume start) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Mike McCune 2016-03-28 19:28:22 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Niels de Vos 2016-06-16 09:47:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.