Bug 1289898 - Without detach tier commit, status changes back to tier migration
Without detach tier commit, status changes back to tier migration
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Reopened, Triaged
Depends On: 1284387 1286974
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 05:04 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286974
Environment:
Last Closed: 2016-04-19 03:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-09 05:04:38 EST
REVIEW: http://review.gluster.org/12921 (tier/glusterd: Check before starting tier daemon during volume start) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-10 04:06:28 EST
REVIEW: http://review.gluster.org/12921 (tier/glusterd: Check before starting tier daemon during volume start) posted (#3) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-12-11 13:52:23 EST
COMMIT: http://review.gluster.org/12921 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 6746376747b0a06def2faff1b6af4b8bd624ed55
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Dec 1 09:11:01 2015 +0000

    tier/glusterd: Check before starting tier daemon during volume start
    
    We start tier daemon when volume is started without looking into the
    previous status. The problem with that if detach-tier is started
    and then volume force start is actually starting tier daemon.
    
    This is also fixes a problem where tier daemon is not starting
    after detach stop.
    
    Back port of>
    >Change-Id: I15b56a711e12f0e24f5ab123561258bd448621f7
    >BUG: 1286974
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12833
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    (cherry picked from commit 28da53e26e88f23f8917810ce0177f2628aa7e9a)
    
    Change-Id: I22c9ad0b2bc4488c15978d8bf85d05113e8b886e
    BUG: 1289898
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12921
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 03:50:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.