Bug 1287004 - Making lookup-optimize on by default
Summary: Making lookup-optimize on by default
Keywords:
Status: CLOSED DUPLICATE of bug 1557435
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard: dht-lookup-optimize
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-01 10:42 UTC by Susant Kumar Palai
Modified: 2018-10-08 04:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-08 04:42:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2015-12-01 10:42:08 UTC
Description of problem:
Currently before creating a file dht will lookup on all subvols for this file, and when it fails with an ENOENT is when the create happens. Such negative lookups can be avoided by making lookup-optimize on, as the lookup goes only on the hashed subvol. However due to parent layout change the hashed subvol of some files can change without proper linkto file.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create distributed volume
2. create some files and observer how lookup is going on all subvols.
3. Now set lookup-optimize on
4. Create a directory and some files inside it. Make sure there are some anomalies while creating the directory.
5. Trigger lookup selfheal on the directory.
6. Some of the files may now hash to other subvols.
7. If lookup-optimize is on it will not find these files.

Actual results:
Not listing some files.

Expected results:
Must list all files correctly.

Additional info:

Comment 1 Vijay Bellur 2015-12-02 06:20:29 UTC
REVIEW: http://review.gluster.org/12841 (glusterd: enable self-heal-daemon for distribute volumes) posted (#1) for review on master by Sakshi Bansal

Comment 2 Vijay Bellur 2015-12-02 15:09:33 UTC
REVIEW: http://review.gluster.org/12841 (glusterd: enable self-heal-daemon for distribute volumes) posted (#2) for review on master by Sakshi Bansal

Comment 3 Vijay Bellur 2015-12-08 05:44:21 UTC
REVIEW: http://review.gluster.org/12841 (glusterd: enable self-heal-daemon for distribute volumes) posted (#3) for review on master by Sakshi Bansal

Comment 4 Vijay Bellur 2015-12-09 03:58:35 UTC
REVIEW: http://review.gluster.org/12841 (glusterd: enable self-heal-daemon for distribute volume) posted (#4) for review on master by Sakshi Bansal

Comment 5 Vijay Bellur 2015-12-09 19:04:10 UTC
REVIEW: http://review.gluster.org/12841 (glusterd: enable self-heal-daemon for distribute volumes) posted (#5) for review on master by Sakshi Bansal

Comment 7 Nithya Balachandran 2018-10-08 04:42:02 UTC

*** This bug has been marked as a duplicate of bug 1557435 ***


Note You need to log in before you can comment on or make changes to this bug.