Bug 1287034 - [abrt] rpmconf: rpmconf.py:166:show_diff:UnboundLocalError: local variable 'fromdate' referenced before assignment
[abrt] rpmconf: rpmconf.py:166:show_diff:UnboundLocalError: local variable 'f...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:008b4feaab24f48a04366ff9263...
:
: 1287039 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 06:13 EST by Christian Stadelmann
Modified: 2015-12-07 15:28 EST (History)
3 users (show)

See Also:
Fixed In Version: rpmconf-1.0.16-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 15:28:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.11 KB, text/plain)
2015-12-01 06:13 EST, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-12-01 06:13:34 EST
Version-Release number of selected component:
rpmconf-1.0.15-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/sbin/rpmconf -a
executable:     /usr/sbin/rpmconf
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
#1 show_diff in /usr/lib/python3.4/site-packages/rpmconf/rpmconf.py:166
#2 _handle_rpmnew in /usr/lib/python3.4/site-packages/rpmconf/rpmconf.py:330
#3 _handle_package in /usr/lib/python3.4/site-packages/rpmconf/rpmconf.py:286
#4 run in /usr/lib/python3.4/site-packages/rpmconf/rpmconf.py:91
#5 main in /usr/sbin/rpmconf:68
#6 <module> in /usr/sbin/rpmconf:77
Comment 1 Christian Stadelmann 2015-12-01 06:13:39 EST
Created attachment 1100840 [details]
File: backtrace
Comment 2 Miroslav Suchý 2015-12-01 07:16:20 EST
*** Bug 1287039 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Suchý 2015-12-01 07:17:16 EST
Fixed in commit:
* cb890b4 1287034 - local variable 'fromdate' referenced before assignment
Comment 4 Fedora Update System 2015-12-01 07:23:52 EST
rpmconf-1.0.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 5 Fedora Update System 2015-12-01 07:24:14 EST
rpmconf-1.0.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 6 Fedora Update System 2015-12-01 17:31:26 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 7 Fedora Update System 2015-12-07 15:28:28 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.