Bug 1287039 - crash when showing differences between versions
crash when showing differences between versions
Status: CLOSED DUPLICATE of bug 1287034
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 06:22 EST by Jiri Popelka
Modified: 2015-12-01 07:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 07:16:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cupsd.conf & cupsd.conf.rpmnew (1.55 KB, application/x-bzip)
2015-12-01 06:22 EST, Jiri Popelka
no flags Details

  None (edit)
Description Jiri Popelka 2015-12-01 06:22:52 EST
Created attachment 1100843 [details]
cupsd.conf & cupsd.conf.rpmnew

Version-Release number of selected component (if applicable):
rpmconf-1.0.15-1.fc23.noarch

Steps to Reproduce:
# rpmconf -a
Configuration file '/etc/cups/cupsd.conf'
-rw-r-----. 1 root lp 3090 30. lis 15.09 /etc/cups/cupsd.conf
-rw-r-----. 1 root lp 4514  1. pro 11.08 /etc/cups/cupsd.conf.rpmnew

 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      M     : merge configuration files
      Z     : background this process to examine the situation
      S     : skip this file
 The default action is to keep your current version.
*** aliases (Y/I/N/O/D/M/Z/S) [default=N] ? 
Your choice: D
Traceback (most recent call last):
  File "/usr/sbin/rpmconf", line 77, in <module>
    main()
  File "/usr/sbin/rpmconf", line 68, in main
    rconf.run()
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 91, in run
    self._handle_package(pkg_hdr)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 286, in _handle_package
    tmp.format(conf_file, "rpmnew"))
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 330, in _handle_rpmnew
    self.show_diff(conf_file, other_file)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 166, in show_diff
    fromdate, todate)
UnboundLocalError: local variable 'fromdate' referenced before assignment
Comment 1 Miroslav Suchý 2015-12-01 07:16:20 EST

*** This bug has been marked as a duplicate of bug 1287034 ***

Note You need to log in before you can comment on or make changes to this bug.