Bug 1287038 - free - error while parsing arguments
free - error while parsing arguments
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: procps-ng (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Jan Rybar
Jan Houska
: Upstream, ZStream
Depends On:
Blocks: 1287174
  Show dependency treegraph
 
Reported: 2015-12-01 06:18 EST by Branislav Náter
Modified: 2016-11-04 02:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: procps-ng-3.3.10-5.el7
Doc Type: Bug Fix
Doc Text:
A fix of Bug 1262864 indirectly triggered a hidden issue in the "free" utility, where missing initialization of the error status variable used for text string to floating point number conversions caused a failure of the "-s", "--seconds" command-line option processing. Consequently, the following message was returned to the user: "free: seconds argument failed". This bug has been fixed, and using the "-s", "--seconds" option with the "free" command no longer leads to failures.
Story Points: ---
Clone Of:
: 1287174 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:36:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch applied to the package (473 bytes, patch)
2016-06-15 09:26 EDT, Jan Rybar
no flags Details | Diff

  None (edit)
Description Branislav Náter 2015-12-01 06:18:43 EST
Description of problem:
After update to procps-ng-3.3.10-4.el7_2, free is failing when interval for printing output is passed (-s, --seconds)

Version-Release number of selected component (if applicable):
procps-ng-3.3.10-4.el7_2

How reproducible:
Always, see bellow

Steps to Reproduce:
1. free -s 2

Actual results:
free: seconds argument `2' failed

Expected results: (output printed every 2 seconds)
              total        used        free      shared  buff/cache   available
Mem:        3882420      211260      799756       25484     2871404     3354752
Swap:             0           0           0
Comment 1 Jaromír Cápík 2015-12-01 06:38:48 EST
I can reproduce this even on Fedora. Looks like triggered by some glibc changes.
Comment 2 Jaromír Cápík 2015-12-01 10:50:43 EST
It's a bug in the free tool. The 'errno' variable is not zeroed prior calling 'strtof'.
Comment 3 Jaromír Cápík 2015-12-01 11:11:36 EST
Unfortunately it's triggered indirectly and blocks the Z-stream fix.
Comment 8 Jan Rybar 2016-06-15 09:26 EDT
Created attachment 1168386 [details]
Patch applied to the package
Comment 9 Jan Rybar 2016-06-15 09:32:52 EDT
Issue already resolved on upstream side in commit https://gitlab.com/procps-ng/procps/commit/fd007d6d1df1714bda1338d8423c8c72238a6a14.
Comment 13 errata-xmlrpc 2016-11-04 02:36:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2447.html

Note You need to log in before you can comment on or make changes to this bug.