Bug 1287160 - hosted-engine-setup can fail too silently
hosted-engine-setup can fail too silently
Status: CLOSED DUPLICATE of bug 1287159
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.General (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 11:11 EST by Simone Tiraboschi
Modified: 2015-12-01 11:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 11:12:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Simone Tiraboschi 2015-12-01 11:11:40 EST
Description of problem:
hosted-engine-setup can fail too silently. As a workaround for a past libvirt issue hosted-engine-setup was closing the stdout before leaving the control to otopi and this can prevent it to clearly show a failure to the user.

Version-Release number of selected component (if applicable):


How reproducible:
it depends from the kind of failure

Steps to Reproduce:
1. check what happens when hosted-engine-setup fails
2.
3.

Actual results:
the failure can be not that evident to the user

Expected results:
In case of a failure we should clearly state that the setup wasn't correctly completed and so the system is not reliable.

Additional info:
Comment 1 Simone Tiraboschi 2015-12-01 11:12:42 EST

*** This bug has been marked as a duplicate of bug 1287159 ***

Note You need to log in before you can comment on or make changes to this bug.