Bug 1287159 - hosted-engine-setup can fail too silently
hosted-engine-setup can fail too silently
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.General (Show other bugs)
1.3.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.2
: 1.3.2
Assigned To: Simone Tiraboschi
Nikolai Sednev
: Triaged
: 1287160 (view as bug list)
Depends On:
Blocks: 1293654
  Show dependency treegraph
 
Reported: 2015-12-01 11:11 EST by Simone Tiraboschi
Modified: 2016-02-18 06:05 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.3.2-1
Doc Type: Bug Fix
Doc Text:
hosted-engine-setup can fail too silently. As a workaround for a past libvirt issue hosted-engine-setup was closing the stdout before leaving the control to otopi and this can prevent it to clearly show a failure to the user. Since the libvirt issue has been fixed we can revert the workaround.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:05:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49565 master MERGED setup: avoid closing stderr and provide a clear exit message Never
oVirt gerrit 50238 ovirt-hosted-engine-setup-1.3 MERGED setup: avoid closing stderr and provide a clear exit message 2015-12-22 04:23 EST

  None (edit)
Description Simone Tiraboschi 2015-12-01 11:11:14 EST
Description of problem:
hosted-engine-setup can fail too silently. As a workaround for a past libvirt issue hosted-engine-setup was closing the stdout before leaving the control to otopi and this can prevent it to clearly show a failure to the user.

Version-Release number of selected component (if applicable):


How reproducible:
it depends from the kind of failure

Steps to Reproduce:
1. check what happens when hosted-engine-setup fails
2.
3.

Actual results:
the failure can be not that evident to the user

Expected results:
In case of a failure we should clearly state that the setup wasn't correctly completed and so the system is not reliable.

Additional info:
Comment 1 Simone Tiraboschi 2015-12-01 11:12:42 EST
*** Bug 1287160 has been marked as a duplicate of this bug. ***
Comment 2 Yedidyah Bar David 2015-12-02 01:59:14 EST
Check src/plugins/ovirt-hosted-engine-setup/libvirt/workarounds.py .
Adding this comment because I wasn't aware of this file.
Comment 3 Sandro Bonazzola 2015-12-23 08:42:20 EST
oVirt 3.6.2 RC1 has been released for testing, moving to ON_QA
Comment 4 Nikolai Sednev 2016-01-14 09:48:38 EST
Works for me on these components:


         Please specify path to OVF archive you would like to use [None]: ^C[ ERROR ] Failed to execute stage 'Environment customization': SIG2
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160114100708.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: this system is not reliable, please check the issue, fix and redeploy
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160114100621-9ajja6.log


HE-Host:
mom-0.5.1-1.el7ev.noarch
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.6-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.5.x86_64
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-host-deploy-1.4.1-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64
sanlock-3.2.4-2.el7_2.x86_64
ovirt-setup-lib-1.0.1-1.el7ev.noarch
vdsm-4.17.15-0.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.1-1.el7ev.noarch

Engine:
ovirt-vmconsole-1.0.0-1.el6ev.noarch
rhevm-dwh-3.6.2-1.el6ev.noarch
rhevm-reports-3.6.2.1-1.el6ev.noarch
ovirt-engine-extension-aaa-jdbc-1.0.4-1.el6ev.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.