Bug 1287218 - hosted engine doesn't get registered to RHEV-M after installation
hosted engine doesn't get registered to RHEV-M after installation
Status: CLOSED DUPLICATE of bug 1274294
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.6.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
:
Depends On:
Blocks: RHEV_36_HTB
  Show dependency treegraph
 
Reported: 2015-12-01 14:24 EST by Martin Tessun
Modified: 2016-05-23 07:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 08:49:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tessun 2015-12-01 14:24:38 EST
Description of problem:
Running hosted-engine deploy does not register the hosted-engine VM to RHEV-M

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

How reproducible:
always

Steps to Reproduce:
1. Install RHEL 7.2 with ovirt-hosted-engine-setup
2. Run hosted-engine --deploy
3. Select iSCSI Storage and PXE installation for hosted engine
4. Install RHEL 6.7 and rhevm to hosted engine
5. After setting up the engine the host gets registered by hosted-engine.

Actual results:
hosted_engine is not shown in RHEV-M Web-UI after installation. The disk is attached to RHEV-M as a Direct attached LUN (like in RHEV 3.5), but the VM does 
The host still shpows 1 VM running. Migration of the hosted-engine is also not possible. Only changes via hosted-engine command are possible.

Expected results:
VM should get imported and visible to RHEV-M after installation. Additionally it should be migrateable and changeable via the Web-UI.

Additional info:
I think there is a similiar ovirt-Bug open, but I was not able to find it.
Comment 1 Martin Tessun 2015-12-01 15:41:32 EST
RHEV-M itself has the Event:
	
Dec 1, 2015 9:33:20 PM
	
The Hosted Engine Storage Domain doesn't no exist. It should be imported into the setup.

But that is not possible, as the domain does not show up as importable.
Comment 2 Sandro Bonazzola 2015-12-02 08:49:37 EST
Thanks for reporting, this is a known issue and already tracked in bug #1274294.

*** This bug has been marked as a duplicate of bug 1274294 ***

Note You need to log in before you can comment on or make changes to this bug.