Bug 1287301 - fence_compute does not advertise itself correctly
fence_compute does not advertise itself correctly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Oyvind Albrigtsen
Asaf Hirshberg
:
Depends On:
Blocks: 1185030 1287303
  Show dependency treegraph
 
Reported: 2015-12-01 17:39 EST by Andrew Beekhof
Modified: 2016-11-04 00:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: fence-agents-4.0.11-38.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:48:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Beekhof 2015-12-01 17:39:33 EST
Description of problem:

fence_compute works more like a fabric fencing device than a network power switch.
It should advertise the fabric_fencing and on_target options to avoid the need for ugly work-arounds in pacemaker.

Version-Release number of selected component (if applicable):

fence-agents-all-4.0.11-27.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. fence_compute -o metadata

Actual results:

...
<actions>
	<action name="on"/>


Expected results:

...
<actions>
	<action name="on" on_target="1" automatic="1"/>

Additional info:

--- /sbin/fence_compute.orig	2015-11-26 20:09:12.165071987 -0500
+++ /sbin/fence_compute	2015-11-30 21:44:08.176674412 -0500
@@ -187,7 +198,7 @@
 	global nova
 	atexit.register(atexit_handler)
 
-	device_opt = ["login", "passwd", "tenant-name", "auth-url",
+	device_opt = ["login", "passwd", "tenant-name", "auth-url", "fabric_fencing", "on_target",
 		"no_login", "no_password", "port", "domain", "no-shared-storage", "endpoint-type",
 		"record-only"]
 	define_new_opts()
Comment 1 Andrew Beekhof 2015-12-02 21:36:00 EST
https://github.com/ClusterLabs/fence-agents/pull/33
Comment 3 Asaf Hirshberg 2016-06-16 07:58:42 EDT
Andrew, 

I got the following the expected result from fence-agents4.0.11-27

</resource-agent>
[root@overcloud-controller-2 ~]# fence_compute -o metadata|grep -A3 action
	<parameter name="action" unique="0" required="1">
		<getopt mixed="-o, --action=[action]" />
		<content type="string" default="off"  />
		<shortdesc lang="en">Fencing Action</shortdesc>
	</parameter>
--
<actions>
	<action name="on" on_target="1" automatic="1"/>
	<action name="off" />
	<action name="status" />
	<action name="list" />
	<action name="list-status" />
	<action name="monitor" />
	<action name="metadata" />
</actions>
</resource-agent>

Did I missed something? as it fixed in fence-agents-4.0.11-38.el7
Comment 4 Andrew Beekhof 2016-06-16 19:10:47 EDT
They must have forgotten to close the bug
Comment 5 Oyvind Albrigtsen 2016-06-17 03:03:37 EDT
Correct.

It was already fixed, so I set Resolves for this bz for fence-agents-4.0.11-38.el7, as that was missing from the changelog.
Comment 7 errata-xmlrpc 2016-11-04 00:48:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2373.html

Note You need to log in before you can comment on or make changes to this bug.