Bug 1287303 - [NovaEvacuate] Fabric fencing devices do not support reboot action
[NovaEvacuate] Fabric fencing devices do not support reboot action
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Oyvind Albrigtsen
Asaf Hirshberg
: ZStream
Depends On: 1287301
Blocks: 1185030 1304019
  Show dependency treegraph
 
Reported: 2015-12-01 17:46 EST by Andrew Beekhof
Modified: 2016-11-03 19:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-55.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304019 (view as bug list)
Environment:
Last Closed: 2016-11-03 19:59:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Beekhof 2015-12-01 17:46:28 EST
Description of problem:

We are changing the way fence_compute advertises itself in Bug #1287301, as a result it will no longer support the 'reboot' action causing evacuations to fail.

We need to change the action to 'off'.

Version-Release number of selected component (if applicable):

resource-agents-3.9.5-54.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1.  Cause a compute node failure
2.
3.

Actual results:

NovaEvacuate's call to fence_compute fails with:

Failed: Unrecognised action 'reboot'

Expected results:

Call passes

Additional info:

  --- /usr/lib/ocf/resource.d/openstack/NovaEvacuate.orig    2015-11-30 21:53:57.868660753 -0500
+++ /usr/lib/ocf/resource.d/openstack/NovaEvacuate    2015-11-30 21:54:40.564659764 -0500
@@ -198,7 +193,7 @@
         return $OCF_SUCCESS
         fi
 
-        fence_compute ${fence_options} -o reboot -n $node
+        fence_compute ${fence_options} -o off -n $node
         rc=$?
 
         if [ $rc = 0 ]; then
Comment 2 Oyvind Albrigtsen 2015-12-08 03:04:52 EST
https://review.openstack.org/#/c/254515/
Comment 12 Asaf Hirshberg 2016-03-08 03:40:52 EST
Verified on RHEL-OSP director 8.0 puddle - 2016-03-03.1

[heat-admin@overcloud-controller-0 ~]$ rpm -qa |grep resource-agents
resource-agents-3.9.5-54.el7_2.6.x86_64
[heat-admin@overcloud-controller-0 ~]$ cat /usr/lib/ocf/resource.d/openstack/NovaEvacuate |grep -n fence_compute
..
201:	    fence_compute ${fence_options} -o off -n $node
..
[heat-admin@overcloud-controller-0 ~]$
Comment 14 errata-xmlrpc 2016-11-03 19:59:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2174.html

Note You need to log in before you can comment on or make changes to this bug.