Bug 1287318 - Serialization error in Bugzilla/BugMail.pm
Serialization error in Bugzilla/BugMail.pm
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Database (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 1298799 1306927 (view as bug list)
Depends On:
Blocks: 1288260
  Show dependency treegraph
 
Reported: 2015-12-01 18:31 EST by Matt Tyson
Modified: 2016-03-02 18:32 EST (History)
8 users (show)

See Also:
Fixed In Version: 4.4.11048.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-14 19:57:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Tyson 2015-12-01 18:31:47 EST
Another serialization error has been reported:

Server error: <Fault 32000: "Red Hat Bugzilla's database reported a query serialization error. Most likely this occurred because another user or process attempted to change the same data that you were attempting to change. Please press Back and retry the transaction. UPDATE bugs SET lastdiffed = ? WHERE bug_id = ? at /var/www/html/bugzilla/Bugzilla/BugMail.pm line 324
Comment 1 Yaniv Kaul 2016-01-10 02:24:06 EST
Same here?

Red Hat Bugzilla's database reported a query serialization error. Most likely this occurred because another user or process attempted to change the same data that you were attempting to change. 

Please press Back and retry the transaction.
UPDATE bugs SET lastdiffed = ? WHERE bug_id = ? at /var/www/html/bugzilla/Bugzilla/BugMail.pm line 324 Bugzilla::BugMail::Send(1295041, 'HASH(0x7fd71fb53e00)', 'HASH(0x7fd725e606d8)') called at /var/www/html/bugzilla/Bugzilla/Bug.pm line 1537 Bugzilla::Bug::_send_bugmail('HASH(0x7fd725e606d8)', 'HASH(0x7fd7263a16e0)') called at /var/www/html/bugzilla/Bugzilla/Bug.pm line 1473 Bugzilla::Bug::send_changes('Bugzilla::Bug=HASH(0x7fd726c27408)', 'HASH(0x7fd726cb9688)', 'HASH(0x7fd7263a16e0)') called at /var/www/html/bugzilla/process_bug.cgi line 509 ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_html_bugzilla_process_bug_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7fd726d5b818)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 204 eval {...} called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 204 ModPerl::RegistryCooker::run('Bugzilla::ModPerl::ResponseHandler=HASH(0x7fd726e32188)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 170 ModPerl::RegistryCooker::default_handler('Bugzilla::ModPerl::ResponseHandler=HASH(0x7fd726e32188)') called at /usr/lib64/perl5/vendor_perl/ModPerl/Registry.pm line 31 ModPerl::Registry::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7fd726d5b818)') called at /var/www/html/bugzilla/mod_perl.pl line 134 Bugzilla::ModPerl::ResponseHandler::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7fd726d5b818)') called at -e line 0 eval {...} called at -e line 0
Comment 2 Yaniv Kaul 2016-01-10 02:25:09 EST
At least in my case, I suspect the bugbot has something to do with it.
Comment 3 Matt Tyson 2016-01-10 22:15:37 EST
Moving to sprint46
Comment 4 Hui Wang 2016-01-12 02:56:03 EST
QE can't reproduce this issue now. And I have discussed with Matt about this issue. So I propose that we can change the status to verified at that moment and we will monitor this issue in production. 
@mtahir, do you have any concern?
Comment 5 Yaniv Lavi 2016-01-12 08:17:42 EST
Try moving bugs from RHEV to another product on oVirt on the partner bugzilla. It should happen if rules engine is synced to there.
Comment 6 Hui Wang 2016-01-12 21:23:53 EST
(In reply to Yaniv Dary from comment #5)
> Try moving bugs from RHEV to another product on oVirt on the partner
> bugzilla. It should happen if rules engine is synced to there.

Yaniv,
Thanks for your feedback.
Partner(4.4.11045.3) has no the update. This commit should be in 4.4.11046.1.
Comment 7 Yaniv Lavi 2016-01-13 05:31:49 EST
(In reply to Hui Wang from comment #6)
> (In reply to Yaniv Dary from comment #5)
> > Try moving bugs from RHEV to another product on oVirt on the partner
> > bugzilla. It should happen if rules engine is synced to there.
> 
> Yaniv,
> Thanks for your feedback.
> Partner(4.4.11045.3) has no the update. This commit should be in 4.4.11046.1.

Is that commit in production already?
Comment 8 Matt Tyson 2016-01-13 17:35:46 EST
(In reply to Yaniv Dary from comment #7)
> Is that commit in production already?

No, when this bug is CLOSED/CURRENTRELEASE the commit will be in production.
Comment 9 Matt Tyson 2016-01-15 01:34:31 EST
Reverting this commit due to a regression.  We'll tackle it in sprint48.
Comment 10 Yedidyah Bar David 2016-01-19 10:43:20 EST
Just in case you need another example, this happened also when bug 1299523 was opened.
Comment 13 Hui Wang 2016-01-28 01:54:56 EST
Verified this issue.
The result is PASS.
version 4.4.11048.1

Steps:

1.Add one new rule or choose one existed rule.
2.In step1, update the "Run after:"  as "Run first" 
3.In step2 and step3, set your conditions and actions
4.In step4, open the "View bug list" on other tap of browser (10<bugs<1000)
5.Submit the change of the rule
6.In the "View bug list" tab, click "Change Several Bugs at Once", do some change and submit

I have tried the same scenario in different env and build, the results are following:

In RDU env(pgpool&version 4.4.11046.4), the issue can be reproduced(the result as in comment #0).
In QE env(no pgpool, version 4.4.11048.1), the issue can't be reproduced.
In RDU env(pgpool&version 4.4.11048.1), the issue can't be reproduced.


If anyone would like to provide any other scenario, welcome!
Comment 14 Hui Wang 2016-01-28 01:56:08 EST
s/In RDU env(pgpool&version 4.4.11046.4), the issue can be reproduced(the result as in comment #0)./In RDU env(pgpool&version 4.4.11046.4), the issue can be reproduced(the result as in comment #1).
Comment 17 Muhammad Tahir 2016-02-07 22:46:17 EST
*** Bug 1298799 has been marked as a duplicate of this bug. ***
Comment 18 Matt Tyson 2016-02-14 19:57:08 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.
Comment 19 Jeff Fearn 2016-02-14 21:56:38 EST
*** Bug 1306927 has been marked as a duplicate of this bug. ***
Comment 20 Yedidyah Bar David 2016-03-02 10:15:23 EST
This now happened to me again, twice in a row. Last one was when filing bug 1313903. Got in the browser:

Red Hat Bugzilla's database reported a query serialization error. Most likely this occurred because another user or process attempted to change the same data that you were attempting to change.

Please press Back and retry the transaction.

UPDATE bugs SET lastdiffed = ? WHERE bug_id = ? at /var/www/html/bugzilla/Bugzilla/BugMail.pm line 324 Bugzilla::BugMail::Send(1313903, 'HASH(0x7ff80dcb6e50)') called at /var/www/html/bugzilla/post_bug.cgi line 259 ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_html_bugzilla_post_bug_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7ff80db7dc48)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 204 eval {...} called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 204 ModPerl::RegistryCooker::run('Bugzilla::ModPerl::ResponseHandler=HASH(0x7ff80d704390)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 170 ModPerl::RegistryCooker::default_handler('Bugzilla::ModPerl::ResponseHandler=HASH(0x7ff80d704390)') called at /usr/lib64/perl5/vendor_perl/ModPerl/Registry.pm line 31 ModPerl::Registry::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7ff80db7dc48)') called at /var/www/html/bugzilla/mod_perl.pl line 134 Bugzilla::ModPerl::ResponseHandler::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7ff80db7dc48)') called at -e line 0 eval {...} called at -e line 0
Comment 21 Matt Tyson 2016-03-02 18:32:14 EST
I've filed bug 1314103 to track this.

Note You need to log in before you can comment on or make changes to this bug.