Bug 1287325 - HAProxy logs show up in /var/log/swift/swift.log
HAProxy logs show up in /var/log/swift/swift.log
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: 12.0 (Pike)
Assigned To: Chris Jones
Udi Shkalim
: InstallerIntegration, Triaged, ZStream
: 1242737 1306170 (view as bug list)
Depends On:
Blocks: 1235795
  Show dependency treegraph
 
Reported: 2015-12-01 19:10 EST by Marius Cornea
Modified: 2018-04-26 05:47 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-08 10:40:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
swift log (456.14 KB, text/plain)
2015-12-01 19:10 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-12-01 19:10:19 EST
Created attachment 1101145 [details]
swift log

Description of problem:
HAProxy logs show up in /var/log/swift/swift.log 

Version-Release number of selected component (if applicable):
RHEL-OSP 7.1

How reproducible:
100%

Steps to Reproduce:
1. Check /var/log/swift/swift.log on the overcloud controller

Actual results:
HAProxy logs show up.

Expected results:
Only swift related logs are shown.

Additional info:
Attaching swift.log
Comment 3 bkopilov 2016-02-10 05:05:41 EST
*** Bug 1306170 has been marked as a duplicate of this bug. ***
Comment 4 Mike Burns 2016-02-10 07:54:39 EST
*** Bug 1242737 has been marked as a duplicate of this bug. ***
Comment 5 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Peter Portante 2016-08-29 13:16:47 EDT
One can use the "programname" field in rsyslog to also select which logs go where instead of facility.

E.g.

if $programname == 'haproxy' then
    action(type="omfile", file="/var/log/haproxy.log")
    stop
endif


Then be sure to order that before the openstack-swift.conf file.

-peter
Comment 8 Lars Kellogg-Stedman 2016-08-29 13:22:54 EDT
Re: comment #7, that's largely what I was thinking.

In particular, I think that we should just modify all the configs to log using the "daemon" facility and then use programname to filtering to separate log files, and leave the local* facilities for use by the local administrator.
Comment 9 Peter Portante 2016-08-29 13:27:36 EDT
That seems like a reasonable solution.
Comment 12 Chris Jones 2018-01-08 10:40:37 EST
This is fixed in OSP12

Note You need to log in before you can comment on or make changes to this bug.