Bug 1287397 - Warning messages observed while using glusterfs as storage during hosted-engine setup
Warning messages observed while using glusterfs as storage during hosted-engi...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Gluster (Show other bugs)
1.3.0
All Linux
medium Severity high (vote)
: ovirt-3.6.3
: 1.3.3.1
Assigned To: Simone Tiraboschi
SATHEESARAN
:
Depends On:
Blocks: Gluster-HC-1 1305885
  Show dependency treegraph
 
Reported: 2015-12-01 20:36 EST by SATHEESARAN
Modified: 2016-02-18 06:02 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEV+RHGS ( Hyperconvergence environment )
Last Closed: 2016-02-18 06:02:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: exception+
ylavi: planning_ack+
sbonazzo: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52443 master MERGED storage: remove mount.glusterfs related warning 2016-02-02 05:56 EST
oVirt gerrit 52444 ovirt-hosted-engine-setup-1.3 MERGED storage: remove mount.glusterfs related warning 2016-02-02 11:49 EST

  None (edit)
Description SATHEESARAN 2015-12-01 20:36:05 EST
Description of problem:
------------------------
while setting up the hosted-engine with glusterfs as a storage domain, there was a warning message - "[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable."

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEL 7.2
RHEV 3.6 Beta1
RHGS 3.1.2 ( nightly builds )

How reproducible:
------------------
Always

Steps to Reproduce:
-------------------
1. Deploy hosted engine ( screen hosted-engine --deploy )
2. While providing storage options, select 'glusterfs' and provide glusterfs volume details

Actual results:
---------------
Explicit warning was thrown - "[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable."

Expected results:
------------------
There should be no warning messages

Additional info:
----------------
          --== STORAGE CONFIGURATION ==--
         
          During customization use CTRL-D to abort.
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs3, nfs4)[nfs3]: glusterfs
[ INFO  ] Please note that Replica 3 support is required for the shared storage.
          Please specify the full shared storage connection path to use (example: host:/path): xxxxxxxxxxxxxx:/enginevol
[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable.
[ INFO  ] GlusterFS replica 3 Volume detected
[ INFO  ] Installing on first host
          Please provide storage domain name. [hosted_storage]: 
          Local storage datacenter name is an internal name
          and currently will not be shown in engine's admin UI.
          Please enter local datacenter name [hosted_datacenter]: 
[WARNING] Due to several bugs in mount.glusterfs the validation of GlusterFS share cannot be reliable.
[ INFO  ] GlusterFS replica 3 Volume detected
Comment 1 SATHEESARAN 2015-12-01 20:39:00 EST
sahina (sabose@redhat.com) has provided the following useful information

<snip>

From the code, the reason for logging warning were below bugs.
These bugs have been fixed now, so warning can be removed. 

FIXME: mount.glusterfs exit with code 0 also on failure
 without any stderr content.
https://bugzilla.redhat.com/show_bug.cgi?id=1128165
https://bugzilla.redhat.com/show_bug.cgi?id=1173513
https://bugzilla.redhat.com/show_bug.cgi?id=1173515

</snip>
Comment 2 Yaniv Lavi 2015-12-09 09:16:11 EST
Can you please block this bug on the gluster bug causing this?
Comment 3 Yaniv Lavi 2015-12-09 10:30:10 EST
This is resolved from the gluster side, please remove the warning.
Comment 4 SATHEESARAN 2016-02-11 08:48:57 EST
Tested with ovirt-hosted-engine-setup-1.3.3.1-1.el7ev.noarch and now the warning messages while using glusterfs for hosted-engine deployment.

Note You need to log in before you can comment on or make changes to this bug.