Bug 1287455 - glusterd: all the daemon's of existing volume stopping upon peer detach
glusterd: all the daemon's of existing volume stopping upon peer detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Satish Mohan
:
Depends On:
Blocks: 1288056
  Show dependency treegraph
 
Reported: 2015-12-02 02:00 EST by Gaurav Kumar Garg
Modified: 2016-06-16 09:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288056 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-12-02 02:00:16 EST
Description of problem:

Currently upon peer detach glusterd stopping all the daemon's of existing volume. 

Expected behaviour:

Upon peer detach it should not stop all the daemon's of existing volume
Comment 1 Vijay Bellur 2015-12-02 02:11:41 EST
REVIEW: http://review.gluster.org/12838 (glusterd: stop daemon services upon peer detach correctly) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-12-02 06:59:42 EST
REVIEW: http://review.gluster.org/12838 (glusterd: stop daemon services upon peer detach correctly) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-12-03 06:28:13 EST
COMMIT: http://review.gluster.org/12838 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit cae9512d60f5715459ea5883c657c679197982d9
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Dec 1 19:14:08 2015 +0530

    glusterd: stop daemon services upon peer detach correctly
    
    Problem:
    Currently glusterd is stopping all the daemons service upon peer detach.
    If user have multi node cluster and if user want to detach any node
    from the cluster, and detached node having stand alone volume then upon
    detaching glusterd stopping all the daemon's of the detached node,
    which is having running volume.
    
    Fix:
    Upon peer detach it should do peer detach cleanup properly and it should
    stop only those daemon on the node on which it require.
    
    Change-Id: I98b8099166f82e235ded6d02261f59a6511a003b
    BUG: 1287455
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12838
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Niels de Vos 2016-06-16 09:47:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.