Bug 1288056 - glusterd: all the daemon's of existing volume stopping upon peer detach
glusterd: all the daemon's of existing volume stopping upon peer detach
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gaurav Kumar Garg
:
Depends On: 1287455
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 07:00 EST by Gaurav Kumar Garg
Modified: 2016-06-05 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287455
Environment:
Last Closed: 2016-02-14 09:42:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-12-03 07:00:33 EST
+++ This bug was initially created as a clone of Bug #1287455 +++

Description of problem:

Currently upon peer detach glusterd stopping all the daemon's of existing volume. 

Expected behaviour:

Upon peer detach it should not stop all the daemon's of existing volume

--- Additional comment from Vijay Bellur on 2015-12-02 02:11:41 EST ---

REVIEW: http://review.gluster.org/12838 (glusterd: stop daemon services upon peer detach correctly) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-02 06:59:42 EST ---

REVIEW: http://review.gluster.org/12838 (glusterd: stop daemon services upon peer detach correctly) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-03 06:28:13 EST ---

COMMIT: http://review.gluster.org/12838 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit cae9512d60f5715459ea5883c657c679197982d9
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Dec 1 19:14:08 2015 +0530

    glusterd: stop daemon services upon peer detach correctly
    
    Problem:
    Currently glusterd is stopping all the daemons service upon peer detach.
    If user have multi node cluster and if user want to detach any node
    from the cluster, and detached node having stand alone volume then upon
    detaching glusterd stopping all the daemon's of the detached node,
    which is having running volume.
    
    Fix:
    Upon peer detach it should do peer detach cleanup properly and it should
    stop only those daemon on the node on which it require.
    
    Change-Id: I98b8099166f82e235ded6d02261f59a6511a003b
    BUG: 1287455
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12838
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Gaurav Kumar Garg 2015-12-03 07:03:28 EST
patch url: http://review.gluster.org/#/c/12873
Comment 2 Vijay Bellur 2015-12-03 23:09:10 EST
COMMIT: http://review.gluster.org/12873 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 4322c4103325c8ddfceafb5b49f96f96890e2f8b
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Dec 1 19:14:08 2015 +0530

    glusterd: stop daemon services upon peer detach correctly
    
    This patch is backport of: http://review.gluster.org/#/c/12838/
    
    Problem:
    Currently glusterd is stopping all the daemons service upon peer detach.
    If user have multi node cluster and if user want to detach any node
    from the cluster, and detached node having stand alone volume then upon
    detaching glusterd stopping all the daemon's of the detached node,
    which is having running volume.
    
    Fix:
    Upon peer detach it should do peer detach cleanup properly and it should
    stop only those daemon on the node on which it require.
    
      >> Change-Id: I98b8099166f82e235ded6d02261f59a6511a003b
      >> BUG: 1287455
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/12838
      >> Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I98b8099166f82e235ded6d02261f59a6511a003b
    BUG: 1288056
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    (cherry picked from commit cae9512d60f5715459ea5883c657c679197982d9)
    Reviewed-on: http://review.gluster.org/12873
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Gaurav Kumar Garg 2016-02-14 09:42:30 EST
GlusterFS v3.7.8 contains a fix for this bug. closing this bug.
Comment 4 Kaushal 2016-04-19 03:50:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.