Bug 1287518 - Creating a new lifecycle environment path throws error message
Creating a new lifecycle environment path throws error message
Status: CLOSED DUPLICATE of bug 1349492
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
: 1331171 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 04:24 EST by Dirk Herrmann
Modified: 2016-06-23 13:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 13:40:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Herrmann 2015-12-02 04:24:39 EST
Description of problem:

While adding a new lifecycle environment to an existing LC ENV path or while creating a new path it throws an error message: 

# hammer lifecycle-environment create \
>    --name "OSE3-PROD" \
>    --description "OpenShift Platform Production Environment" \
>    --prior "OSE3-DevQA" \
>    --organization "$ORG"
Could not create environment:
  Validation failed: Locations you cannot remove locations that are used by hosts or inherited., Environments you cannot remove environments that are used by hosts or inherited.

Using WebUI after clicking Save button the page does not reload and the same error message appears in foreman production log.

Nevertheless in both cases the new LC ENV has been successfully created.

Version-Release number of selected component (if applicable):


How reproducible:

Create a new LC ENV using hammer CLI or WebUI.

Steps to Reproduce:
1. 
2.
3.

Actual results:

Error message but LC ENV is created.

Expected results:

No error message and using WebUI page reload shows again the LC ENV main page.


Additional info:
Comment 3 Brad Buckingham 2016-04-20 13:47:30 EDT
The error message on this bug is very similar to bug 1326101.
Comment 4 Brad Buckingham 2016-05-02 16:47:24 EDT
*** Bug 1331171 has been marked as a duplicate of this bug. ***
Comment 6 Brad Buckingham 2016-06-23 13:40:12 EDT

*** This bug has been marked as a duplicate of bug 1349492 ***

Note You need to log in before you can comment on or make changes to this bug.