Bug 1287563 - containers: No Class found for explorer tree node id '1-' [container/reload]
containers: No Class found for explorer tree node id '1-' [container/reload]
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
high Severity high
: GA
: 5.6.0
Assigned To: Daniel Korn
Dafna Ron
container
:
Depends On:
Blocks: 1289694
  Show dependency treegraph
 
Reported: 2015-12-02 06:02 EST by Dafna Ron
Modified: 2016-06-29 11:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289694 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:15:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (343.10 KB, application/x-gzip)
2015-12-02 06:02 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-12-02 06:02:43 EST
Created attachment 1101413 [details]
logs

Description of problem:

After selecting timeline for container and pressing the reload button, we are getting "No Class found for explorer tree node id '1-' [container/reload] " error

Version-Release number of selected component (if applicable):
cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to containers ->containers
2. select the first container from the list 
3. select "timeline" -> set the date
4. press the reload button 
5. navigate to "all containers" 
6. move between the different containers 

Actual results:

All containers have the same error 
"containers: No Class found for explorer tree node id '1-' [container/reload] "

Expected results:

We should re-load the page

Additional info: logs will be attached

 Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine. Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
      Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
      Please contact your administrator for assistance.


Error text:

No Class found for explorer tree node id '1-' [container/reload]
Comment 1 Federico Simoncelli 2015-12-02 06:32:02 EST
Possible duplicate of bug #1286247
Comment 2 Daniel Korn 2015-12-08 09:24:38 EST
The crash occurs when pressing the reload button when in a container Timelines or Utilization
Comment 3 Federico Simoncelli 2015-12-09 05:47:32 EST
Is this BZ fixed by?

https://github.com/ManageIQ/manageiq/pull/5738
Comment 4 Daniel Korn 2015-12-17 02:53:59 EST
(In reply to Federico Simoncelli from comment #3)
> Is this BZ fixed by?
> 
> https://github.com/ManageIQ/manageiq/pull/5738

yes, this is the containers page refactor we discussed.
Comment 5 Federico Simoncelli 2015-12-17 03:47:55 EST
(In reply to Daniel Korn from comment #4)
> (In reply to Federico Simoncelli from comment #3)
> > Is this BZ fixed by?
> > 
> > https://github.com/ManageIQ/manageiq/pull/5738
> 
> yes, this is the containers page refactor we discussed.

Have you verified that it's fixed by that PR? If so this should be on POST.
Comment 6 Daniel Korn 2015-12-17 04:17:56 EST
(In reply to Federico Simoncelli from comment #5)
> (In reply to Daniel Korn from comment #4)
> > (In reply to Federico Simoncelli from comment #3)
> > > Is this BZ fixed by?
> > > 
> > > https://github.com/ManageIQ/manageiq/pull/5738
> > 
> > yes, this is the containers page refactor we discussed.
> 
> Have you verified that it's fixed by that PR? If so this should be on POST.

I have. Done.
Comment 7 CFME Bot 2015-12-17 12:51:55 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b4c3a6e1fef3e8a015181c3e2f40d004860abfbd

commit b4c3a6e1fef3e8a015181c3e2f40d004860abfbd
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Dec 7 16:14:34 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Dec 17 09:57:04 2015 -0500

    Moved Timelines & Utilization buttons to summary screen from list view.
    
    - Fixed Timelines & Utilization buttons to go thru x_button method similar to all other toolbar buttons and removed any code that is not needed in explorer & show method.
    - Added spec tests to verify Timelines & Utilization buttons render correct views.
    (cherry picked from commit dfdb14f)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289694
    https://bugzilla.redhat.com/show_bug.cgi?id=1287563

 app/controllers/container_controller.rb       | 52 ++++++++++-----------------
 product/toolbars/container_center_tb.yaml     | 17 +++++++++
 product/toolbars/containers_center_tb.yaml    | 22 ++----------
 spec/controllers/container_controller_spec.rb | 38 ++++++++++++++++++++
 4 files changed, 76 insertions(+), 53 deletions(-)
Comment 8 CFME Bot 2015-12-17 12:52:12 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5c15ac9822d53e19dd30ec2146c5fe637b51bf6f

commit 5c15ac9822d53e19dd30ec2146c5fe637b51bf6f
Merge: 11243fa b4c3a6e
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Dec 17 12:49:15 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Dec 17 12:49:15 2015 -0500

    Merge branch '55z_pr_5738' into '5.5.z'
    
    Moved Timelines & Utilization buttons to summary screen from list view.
    
    - Fixed Timelines & Utilization buttons to go thru x_button method similar to all other toolbar buttons and removed any code that is not needed in explorer & show method.
    - Added spec tests to verify Timelines & Utilization buttons render correct views.
    (cherry picked from commit dfdb14f)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289694
    https://bugzilla.redhat.com/show_bug.cgi?id=1287563
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5738
    
    See merge request !634

 app/controllers/container_controller.rb       | 52 ++++++++++-----------------
 product/toolbars/container_center_tb.yaml     | 17 +++++++++
 product/toolbars/containers_center_tb.yaml    | 22 ++----------
 spec/controllers/container_controller_spec.rb | 38 ++++++++++++++++++++
 4 files changed, 76 insertions(+), 53 deletions(-)
Comment 10 errata-xmlrpc 2016-06-29 11:15:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.