Bug 1287755 - non-admin users are unable to view saved reports
non-admin users are unable to view saved reports
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
All All
high Severity high
: GA
: 5.5.2
Assigned To: lgalis
Jan Krocil
: ZStream
Depends On: 1281891 1287759
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 10:39 EST by Chris Pelland
Modified: 2016-02-10 10:20 EST (History)
14 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, users with only view permission for reports were unable to view saved reports. This was because the Saved Reports accordion only had an option to modify or delete saved reports. If the user did not have those permissions, the user would not be able to view the saved reports. This bug was fixed by adding a View option under the Saved Reports accordion. Users with only view permissions are now able to view saved reports in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1281891
Environment:
Last Closed: 2016-02-10 10:20:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2015-12-08 18:51:47 EST
New commit detected on cloudforms/cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=326e0967348f87cbef70ed76e6bf5c4a03c62b7a

commit 326e0967348f87cbef70ed76e6bf5c4a03c62b7a
Author:     Laura Galis <lgalis@redhat.com>
AuthorDate: Tue Dec 8 17:10:03 2015 -0500
Commit:     Laura Galis <lgalis@redhat.com>
CommitDate: Tue Dec 8 17:10:03 2015 -0500

    Fixed the number of features in miq_features_spec for the View Saved Report feature
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287755

 spec/models/miq_product_feature_spec.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 4 CFME Bot 2015-12-08 18:51:52 EST
New commit detected on cloudforms/cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=881da60052fb29c200cc431e721f38cc7240e440

commit 881da60052fb29c200cc431e721f38cc7240e440
Merge: d09265a 326e096
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Dec 8 18:20:18 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Dec 8 18:20:18 2015 -0500

    Merge branch '5.5.z_fix_feature_number_for_view_saved_reports_spec' into '5.5.z'
    
    Fix the number of features in miq_features_spec for the View Saved Report feature
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287755
    
    See merge request !597

 spec/models/miq_product_feature_spec.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 Jan Krocil 2016-01-20 12:53:06 EST
Verified fixed in 5.2.2.1 - 5.5.2.1.20160114044944_395c086.

User can now have access to only Saved Reports through the newly-added "View" checkbox located under "Cloud Intelligence > Reports > Saved Reports" in RBAC.

Note:
Saved reports are still filtered by group as of 5.2.2.1; i.e. the user viewing the saved reports must be in the same group as the group the reports were generated for.
Comment 7 Jan Krocil 2016-01-20 12:53:39 EST
Apologies for the needinfo; removing it.
Comment 8 errata-xmlrpc 2016-02-10 10:20:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.