This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1287759 - non-admin users are unable to view saved reports
non-admin users are unable to view saved reports
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
All All
high Severity high
: GA
: 5.4.5
Assigned To: lgalis
Taras Lehinevych
: ZStream
Depends On: 1281891 1289691
Blocks: 1287755
  Show dependency treegraph
 
Reported: 2015-12-02 10:40 EST by Chris Pelland
Modified: 2017-07-14 10:45 EDT (History)
16 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, non-admin users having only "view" permission on reports were unable to view saved reports. This was because there was only a single feature, "Modify/Delete", below the Saved Reports accordion feature, and turning that off also turned off the parents, thereby losing the entire accordion. With this release, added a new view feature under Saved Reports accordion which resolves this issue. Non-admin users are now able to view saved reports.
Story Points: ---
Clone Of: 1281891
Environment:
Last Closed: 2016-03-29 10:15:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 7 Taras Lehinevych 2016-03-21 08:41:22 EDT
Thank you for information.
I'll wait for fix https://bugzilla.redhat.com/show_bug.cgi?id=1289691 and test it properly.
Comment 8 Taras Lehinevych 2016-03-22 09:19:45 EDT
Verified in 5.4.5.2
Comment 10 errata-xmlrpc 2016-03-29 10:15:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.