Bug 1287841 - Transaction error leads to fast installer crash without warning or errors give to user
Transaction error leads to fast installer crash without warning or errors giv...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 14:41 EST by Terje Røsten
Modified: 2015-12-07 07:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 07:53:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (42.33 KB, text/plain)
2015-12-05 09:10 EST, Terje Røsten
no flags Details
dnf.librepo.log (2.53 MB, text/plain)
2015-12-05 09:10 EST, Terje Røsten
no flags Details
dnf.log (381.97 KB, text/plain)
2015-12-05 09:11 EST, Terje Røsten
no flags Details
dnf.rpm.log (50 bytes, text/plain)
2015-12-05 09:11 EST, Terje Røsten
no flags Details
hawkey.log (7.48 KB, text/plain)
2015-12-05 09:11 EST, Terje Røsten
no flags Details
ifcfg.log (4.85 KB, text/plain)
2015-12-05 09:12 EST, Terje Røsten
no flags Details
packaging.log (6.84 KB, text/plain)
2015-12-05 09:12 EST, Terje Røsten
no flags Details
program.log (77.99 KB, text/plain)
2015-12-05 09:13 EST, Terje Røsten
no flags Details
storage.log (124.43 KB, text/plain)
2015-12-05 09:13 EST, Terje Røsten
no flags Details
vncserver.log (832 bytes, text/plain)
2015-12-05 09:14 EST, Terje Røsten
no flags Details

  None (edit)
Description Terje Røsten 2015-12-02 14:41:14 EST
Description of problem:

Kickstart based install crashed every time after downloading all
packages.

Using ssh option and tailing logs I found:

20:25:45,462 INFO packaging: Downloading packages finished.
20:25:54,771 ERR packaging: The transaction process has ended abruptly
20:25:54,771 INFO packaging: Transaction check error:
  file /etc/logrotate.d/syslog conflicts between attempted installs of syslog-ng-3.6.2-3.fc23.x86_64 and rsyslog-8.10.0-1.fc23.x86_64
  file /etc/xdg/menus/mate-preferences-categories.menu conflicts between attempted installs of mate-menus-preferences-category-menu-1.10.0-2.fc23.x86_64 and mate-control-center-1.12.0-2.fc23.x86_64


Clearly these packages are buggy (rsyslog/rsyslog-ng has been reported months ago with patch to fix), however just crashing installer leaving user without a clue what's wrong nor with an option to ignore the issue is not very friendly.

Crashing after file systems have been created and packages downloaded makes it even more frustrating.

Please try to detect error more early and add option to ignore such problems.

Even very old versions of anaconda (even before Fedora) had this option
if I remember correctly.
Comment 1 David Shea 2015-12-02 14:54:19 EST
Please attach the logs from /tmp to this bug as individual, text/plain attachments.
Comment 2 Terje Røsten 2015-12-02 14:55:52 EST
That's of course not possible as the installer crashes and reboots and everything in /tmp is gone for good.
Comment 3 David Shea 2015-12-02 14:56:44 EST
Can you add inst.nokill to the boot arguments?
Comment 4 Terje Røsten 2015-12-02 14:58:54 EST
Seems useful, thanks.
Comment 5 Terje Røsten 2015-12-05 09:10 EST
Created attachment 1102525 [details]
anaconda.log
Comment 6 Terje Røsten 2015-12-05 09:10 EST
Created attachment 1102526 [details]
dnf.librepo.log
Comment 7 Terje Røsten 2015-12-05 09:11 EST
Created attachment 1102527 [details]
dnf.log
Comment 8 Terje Røsten 2015-12-05 09:11 EST
Created attachment 1102528 [details]
dnf.rpm.log
Comment 9 Terje Røsten 2015-12-05 09:11 EST
Created attachment 1102529 [details]
hawkey.log
Comment 10 Terje Røsten 2015-12-05 09:12 EST
Created attachment 1102530 [details]
ifcfg.log
Comment 11 Terje Røsten 2015-12-05 09:12 EST
Created attachment 1102531 [details]
packaging.log
Comment 12 Terje Røsten 2015-12-05 09:13 EST
Created attachment 1102532 [details]
program.log
Comment 13 Terje Røsten 2015-12-05 09:13 EST
Created attachment 1102533 [details]
storage.log
Comment 14 Terje Røsten 2015-12-05 09:14 EST
Created attachment 1102534 [details]
vncserver.log
Comment 15 Terje Røsten 2015-12-05 09:26:58 EST
tail of packaging.log:

15:39:16,380 INFO packaging: kernel: selected kernel
15:39:16,820 INFO packaging: Sufficient mountpoints found: {'/mnt/sysimage/var': Size('4,84 GiB'), '/mnt/sysimage': Size('24,37 GiB')}
15:39:16,821 INFO packaging: 3295 packages selected totalling 17,3 GiB
15:39:16,856 INFO packaging: Sufficient mountpoints found: {'/mnt/sysimage/var': Size('4,84 GiB'), '/mnt/sysimage': Size('24,37 GiB')}
15:39:17,163 INFO packaging: Downloading packages.
15:04:58,880 INFO packaging: Downloading packages finished.
15:05:12,609 ERR packaging: The transaction process has ended abruptly
15:05:12,609 INFO packaging: Transaction check error:
  file /etc/logrotate.d/syslog conflicts between attempted installs of syslog-ng-3.6.2-3.fc23.x86_64 and rsyslog-8.10.0-1.fc23.x86_64
  file /etc/xdg/menus/mate-preferences-categories.menu conflicts between attempted installs of mate-menus-preferences-category-menu-1.10.0-2.fc23.x86_64 and mate-control-center-1.12.0-2.fc23.x86_64
Comment 16 David Shea 2015-12-07 07:53:05 EST
Thank you for the logs. This behavior is fixed in rawhide by https://github.com/rhinstaller/anaconda/commit/7bdd331b, but unfortunately did not make it into F23. This commit would have caused a traceback instead of a silent exit, and it looks like the underlying cause will be fixed once the change for bug 1287845 is pushed to stable.

Note You need to log in before you can comment on or make changes to this bug.