Bug 1287891 - ManageIQ Automate domain cleanup
ManageIQ Automate domain cleanup
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: mkanoor
Matouš Mojžíš
automate
:
Depends On:
Blocks: 1288150 1353233
  Show dependency treegraph
 
Reported: 2015-12-02 18:12 EST by mkanoor
Modified: 2016-08-17 14:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1288150 1353233 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:16:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
differencies (1.50 KB, text/plain)
2016-05-24 07:01 EDT, Matouš Mojžíš
no flags Details

  None (edit)
Description mkanoor 2015-12-02 18:12:09 EST
Description of problem:
The Automate DB uses YAML files to store the domain, namespace, class, instance and methods on the disk under db/fixtures/ae_datastore/ManageIQ. Some of these YAML files were hand edited leading to inconsistencies and also incorrect names of YAML files.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Export the ManageIQ domain
2. Compare the Exported data with the YAML files on the disk.
3.

Actual results:


Expected results:
The exported data should match the data in the YAML files


Additional info:
Comment 2 mkanoor 2015-12-03 11:56:16 EST
Fixed in PR https://github.com/ManageIQ/manageiq/pull/5649
Comment 3 Matouš Mojžíš 2016-05-13 08:29:40 EDT
I have found, that there are folders, which have different names. For example:
ManageIQ/System/Event/EmsEvent/OPENSTACK.class in db fixture
ManageIQ/System/Event/EmsEvent/OpenStack.class in exported domain
Should it be case sensitive or not?
Comment 4 mkanoor 2016-05-23 10:01:48 EDT
You should look at the internal name in the __class__.yaml file. Typically everything in Automate Name search is case insensitive

If the __class__.yaml has a different name from the folder, it might make sense to make them consistent.
Comment 5 Matouš Mojžíš 2016-05-24 07:00:43 EDT
Okay, still found some differences. 
More in attachment.
Comment 6 Matouš Mojžíš 2016-05-24 07:01 EDT
Created attachment 1160981 [details]
differencies
Comment 8 CFME Bot 2016-06-02 14:11:03 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/236bc8f86b878eada54c39ef1a1ac0f74ffff820

commit 236bc8f86b878eada54c39ef1a1ac0f74ffff820
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Wed Jun 1 12:21:04 2016 -0400
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Wed Jun 1 12:21:04 2016 -0400

    Cleanup ManageIQ domain
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287891

 .../StateMachine/Deployment.class/__class__.yaml   |  20 +-
 .../ContainerProvider/__namespace__.yaml           |  10 +-
 .../Event/EmsEvent/GOOGLE.class/__class__.yaml     | 600 ++++++++++-----------
 .../Event/EmsEvent/GOOGLE.class/_missing.yaml      |   6 +-
 .../GOOGLE.class/compute_instances_delete.yaml     |   6 +-
 .../GOOGLE.class/compute_instances_insert.yaml     |   6 +-
 .../GOOGLE.class/compute_instances_start.yaml      |   6 +-
 .../GOOGLE.class/compute_instances_stop.yaml       |   6 +-
 8 files changed, 330 insertions(+), 330 deletions(-)
Comment 11 mkanoor 2016-06-27 14:50:10 EDT
Matous
Have you gotten a chance to test this?
Thanks,
Madhu
Comment 13 errata-xmlrpc 2016-06-29 11:16:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348
Comment 14 mkanoor 2016-08-17 14:05:56 EDT
Provided Info to QE

Note You need to log in before you can comment on or make changes to this bug.