Bug 1288150 - ManageIQ Automate domain cleanup
ManageIQ Automate domain cleanup
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: mkanoor
Kyrylo Zvyagintsev
: ZStream
Depends On: 1287891 1353233
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 11:56 EST by mkanoor
Modified: 2016-07-06 11:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287891
Environment:
Last Closed: 2016-02-10 10:21:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 mkanoor 2015-12-03 16:53:40 EST
Waiting on MR 
http://gitlab.cloudforms.lab.eng.rdu2.redhat.com/cloudforms/cfme/merge_requests/577
to get merged
Comment 3 CFME Bot 2015-12-07 13:51:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ff17a0f93e186b65c45ddb5b049cccc64f83fbbe

commit ff17a0f93e186b65c45ddb5b049cccc64f83fbbe
Merge: c2fd5e1 dffa8a9
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Mon Dec 7 13:47:38 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Mon Dec 7 13:47:38 2015 -0500

    Merge branch 'bugzilla_1288150_5_5_z' into '5.5.z'
    
    Automate DB round trip cleanup
    
    (1) Two instances were incorrectly named
    (2) Many of the instances were manually edited and imported
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288150
    
    Clean Cherry Pick from https://github.com/ManageIQ/manageiq/pull/5649
    
    See merge request !577

 .../Operations/Methods.class/available_flavors.yaml       |  1 -
 .../Operations/Methods.class/available_images.yaml        |  1 -
 .../Operations/Methods.class/available_os_types.yaml      |  1 -
 .../__methods__/servicereconfigurerequest_approved.yaml   | 12 ++++++++++++
 .../servicetemplatereconfigurerequest_approved.yaml       | 12 ------------
 .../StateMachines/Reconfigure.class/__class__.yaml        | 15 ++++++++++-----
 .../StateMachines/Provision.class/__class__.yaml          | 10 +++++-----
 .../StateMachines/Provision.class/default.yaml            | 10 ----------
 .../Provision.class/provision_via_foreman.yaml            | 10 ++++++++++
 .../__methods__/validate_request.rb                       |  1 +
 .../__methods__/validate_quotas.rb                        |  1 +
 .../service_reconfigure_finished.yaml                     |  4 ++--
 .../EmsEvent/KUBERNETES.class/container_killing.yaml      |  6 +++---
 .../EmsEvent/KUBERNETES.class/container_stopped.yaml      |  6 +++---
 .../EmsEvent/KUBERNETES.class/container_unhealthy.yaml    |  6 +++---
 .../Event/EmsEvent/KUBERNETES.class/node_failedmount.yaml |  6 +++---
 .../KUBERNETES.class/node_invaliddiskcapacity.yaml        |  6 +++---
 .../KUBERNETES.class/node_nodenotschedulable.yaml         |  6 +++---
 .../EmsEvent/KUBERNETES.class/node_nodeschedulable.yaml   |  6 +++---
 .../EmsEvent/KUBERNETES.class/pod_deadlineexceeded.yaml   |  6 +++---
 .../Event/EmsEvent/KUBERNETES.class/pod_failedsync.yaml   |  6 +++---
 .../KUBERNETES.class/pod_insufficientfreecpu.yaml         |  6 +++---
 .../KUBERNETES.class/pod_insufficientfreememory.yaml      |  6 +++---
 .../KUBERNETES.class/pod_nodeselectormismatching.yaml     |  6 +++---
 .../Event/EmsEvent/KUBERNETES.class/pod_outofdisk.yaml    |  6 +++---
 .../KUBERNETES.class/replicator_failedcreate.yaml         |  6 +++---
 .../KUBERNETES.class/replicator_successfulcreate.yaml     |  6 +++---
 27 files changed, 86 insertions(+), 82 deletions(-)
Comment 6 errata-xmlrpc 2016-02-10 10:21:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.