Bug 1287905 - Improve pool creation API to allow the creation of erasure-coded pools
Improve pool creation API to allow the creation of erasure-coded pools
Status: CLOSED DUPLICATE of bug 1382032
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.1
Assigned To: Andrew Schoen
shylesh
Bara Ancincova
:
Depends On: 1287904 1382032
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2015-12-02 19:04 EST by Gregory Meno
Modified: 2016-11-10 09:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Documented with BZ#1287904
Story Points: ---
Clone Of: 1287904
Environment:
Last Closed: 2016-10-05 10:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory Meno 2015-12-02 19:04:00 EST
+++ This bug was initially created as a clone of Bug #1287904 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Gregory Meno 2016-01-27 16:52:02 EST
at a minimum this is as simple as adding the additional parameters to allow https://github.com/ceph/calamari/blob/master/cthulhu/cthulhu/manager/pool_request_factory.py
to accept 
ceph osd pool create ecpool 12 12 erasure

that looks like a day or two effort
Comment 7 Harish NV Rao 2016-06-10 07:45:09 EDT
I am able to create the erasure coded pool using the cli api but once api completes successfully it prints as follows:

HTTP 200 OK
Vary: Accept
Content-Type: text/html; charset=utf-8
Allow: POST, OPTIONS

{
    "out": "", 
    "err": "pool 'ecpool_test5' created\n", 
    "status": 0
}

Note here that "pool 'ecpool_test5' created\n" is a message indicating successful creation of pool but is printed as "err". This message should have been printed against "out". 

Tested on:
calamari-server-1.4.0-0.12.rc15.el7cp.x86_64
ceph version 10.2.1-13.el7cp
Comment 8 Gregory Meno 2016-06-14 12:39:26 EDT
I'll fix in 2.1
Comment 12 Andrew Schoen 2016-10-05 10:46:39 EDT
This ticket was reopened for an error that was different than the original bug. I've opened a new ticket to track this new bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1382032

*** This bug has been marked as a duplicate of bug 1382032 ***

Note You need to log in before you can comment on or make changes to this bug.