Bug 1287904 - Provide API for creating pool snapshots
Provide API for creating pool snapshots
Status: CLOSED DUPLICATE of bug 1382032
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.1
Assigned To: Andrew Schoen
Harish NV Rao
Bara Ancincova
:
Depends On:
Blocks: 1287905 1291304 1322504 1382032
  Show dependency treegraph
 
Reported: 2015-12-02 19:01 EST by Gregory Meno
Modified: 2016-11-10 04:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
.The Calamari API sometimes incorrectly prints standard output as an error When using the Calamari `/cli` endpoint, the Calamari API response swaps the standard output (`stdout`) and standard error (`stderr`). As a consequence, the `err` field contains information from the `stdout` field. This behavior does not have any impact on the Calamari API commands.
Story Points: ---
Clone Of:
: 1287905 1291304 1382032 (view as bug list)
Environment:
Last Closed: 2016-10-05 10:44:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 6906 None None None 2016-06-14 12:13 EDT

  None (edit)
Description Gregory Meno 2015-12-02 19:01:07 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gregory Meno 2016-01-27 17:17:01 EST
http://tracker.ceph.com/issues/6906

https://ceph.com/dev-notes/rados-snapshots/

4 days to implement
Comment 3 Gregory Meno 2016-04-11 19:42:58 EDT
http://hostname:8002/api/v2/cluster/<fsid>/cli

POST
{
    "command": ["ceph", "osd", "pool", "mksnap", "rbd", "rbd_snapshot", "--format=json-pretty"]
}
Comment 4 Harish NV Rao 2016-06-10 08:13:17 EDT
I am able to create the pool snapshots using the cli api but once api completes successfully it prints as follows:
{
    "out": "", 
    "err": "created pool ecpool_test3 snap ecpool_test3_snapshot_2\n", 
    "status": 0
}

Note here that "created pool ecpool_test3 snap ecpool_test3_snapshot_2\n" is a message indicating successful creation of pool but is printed as "err". This message should have been printed against "out". 

Looks like this is happening for all the create commands that print success message.

Tested on:
calamari-server-1.4.0-0.12.rc15.el7cp.x86_64
ceph version 10.2.1-13.el7cp
Comment 6 Gregory Meno 2016-06-14 12:38:29 EDT
I'll fix it in 2.1
Comment 11 Gregory Meno 2016-06-20 14:00:27 EDT
This is wrong and to generic "When using the `create` command in the Calamari REST-based API to create for example pools or pool snapshots,"

I recommend saying specifically, "When using the /cli endpoint Calamari API response swaps stdout and stderr, e.g. the err field actually contains stdout"
Comment 14 Gregory Meno 2016-07-13 12:07:16 EDT
Looks fine
Comment 16 Andrew Schoen 2016-10-05 10:44:47 EDT
This ticket was reopened for an error that was different than the original bug. I've opened a new ticket to track this new bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1382032

*** This bug has been marked as a duplicate of bug 1382032 ***

Note You need to log in before you can comment on or make changes to this bug.