Bug 1287996 - [Quota]: Peer status is in "Rejected" state with Quota enabled volume
[Quota]: Peer status is in "Rejected" state with Quota enabled volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1287980
Blocks: 1288052
  Show dependency treegraph
 
Reported: 2015-12-03 04:25 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287980
: 1288052 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:48:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-03 04:29:14 EST
REVIEW: http://review.gluster.org/12865 (glusterd/quota: quota-version conflict in export/import volinfo) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-03 06:02:13 EST
REVIEW: http://review.gluster.org/12865 (glusterd/quota: quota-version conflict in export/import volinfo) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-12-03 06:46:23 EST
REVIEW: http://review.gluster.org/12865 (glusterd/quota: quota-version conflict in export/import volinfo) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-12-09 02:21:19 EST
COMMIT: http://review.gluster.org/12865 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 156022b67f5da2ca27a607ee9e7608fdf5e91a20
Author: vmallika <vmallika@redhat.com>
Date:   Thu Dec 3 14:55:36 2015 +0530

    glusterd/quota: quota-version conflict in export/import volinfo
    
    When exporting/importing voinfo during handshake,
    quota conf and quota xattr version were using same key
    'quota-version' and updated wrong values when importing
    quota version values.
    
    Change-Id: If939d6f5bc4851d4114963877be72dda21834f0f
    BUG: 1287996
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12865
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:48:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.