Bug 1288052 - [Quota]: Peer status is in "Rejected" state with Quota enabled volume
[Quota]: Peer status is in "Rejected" state with Quota enabled volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
x86_64 Linux
unspecified Severity high
: 3.7.5
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1287980 1287996
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 06:49 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287996
Environment:
Last Closed: 2016-04-19 03:50:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-03 06:50:46 EST
REVIEW: http://review.gluster.org/12872 (glusterd/quota: quota-version conflict in export/import volinfo) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-08 00:25:55 EST
REVIEW: http://review.gluster.org/12872 (glusterd/quota: quota-version conflict in export/import volinfo) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 02:25:30 EST
COMMIT: http://review.gluster.org/12872 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit f18432dde90fbea02ff656eecc916e8b04e0d516
Author: vmallika <vmallika@redhat.com>
Date:   Thu Dec 3 14:55:36 2015 +0530

    glusterd/quota: quota-version conflict in export/import volinfo
    
    This is a backport of http://review.gluster.org/#/c/12865/
    
    When exporting/importing voinfo during handshake,
    quota conf and quota xattr version were using same key
    'quota-version' and updated wrong values when importing
    quota version values.
    
    > Change-Id: If939d6f5bc4851d4114963877be72dda21834f0f
    > BUG: 1287996
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Ic234d9e496f1372789112a0b82ba5cf34014de64
    BUG: 1288052
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12872
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Kaushal 2016-04-19 03:50:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.