Bug 1288058 - Error building timeline Task has been queued when switching between detailed and summary too fast
Error building timeline Task has been queued when switching between detailed ...
Status: CLOSED DUPLICATE of bug 1282647
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.6.0
Assigned To: Dan Clarizio
Avi Tal
container
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 07:07 EST by Dafna Ron
Modified: 2016-04-22 00:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 15:14:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshot (636.71 KB, application/x-gzip)
2015-12-03 07:07 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2015-12-03 07:07:11 EST
Created attachment 1101793 [details]
logs and screenshot

Description of problem:

I switched between detailed view and summary view without waiting for results to show and I got an error that disappears after 10 seconds:
Error building timeline Task has been queued
Since there is no sign for the user that anything is actually happening with the request I think this would happen for impatient people such as myself

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to containers -> providers ->select provider
2. select monitoring -> timeline
3. in the "Level" scroll switch between summary to detailed and back to summary (without waiting for results)

Actual results:

we get a flash error: Error building timeline Task has been queued

Expected results:

Any of these would be fine: 
1. add a sign that the request is being handled
2. do not allow moving between the scrolls as long as a request is in process
3. ask user if they would like to cancel request
4. change error message to something clearer.

Additional info:screenshot and logs
Comment 1 Harpreet Kataria 2015-12-03 15:14:00 EST
Spinners were added in the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1282647

*** This bug has been marked as a duplicate of bug 1282647 ***

Note You need to log in before you can comment on or make changes to this bug.