Bug 1288122 - version update for default cluster fails with NPE
version update for default cluster fails with NPE
Status: CLOSED DUPLICATE of bug 1261851
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 10:20 EST by Piotr Kliczewski
Modified: 2015-12-04 10:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 09:13:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Piotr Kliczewski 2015-12-03 10:20:56 EST
Description of problem:

When using freshly installed engine with clean db changing cluster version fails with NPE on the backend.

Version-Release number of selected component (if applicable):


How reproducible:
100% reproducible


Steps to Reproduce:
1. Install ovirt-engine (no contents in db)
2. edit DC and change version to 3.5
3. edit cluster and change version to 3.5 (no changes to cpu type, ui do not require it)

Actual results:
engine backend fails with NPE:

2015-12-03 16:05:37,480 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (default task-29) [] Query 'GetClusterEditWarningsQuery' failed: null
2015-12-03 16:05:37,480 ERROR [org.ovirt.engine.core.bll.GetClusterEditWarningsQuery] (default task-29) [] Exception: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.UnsupportedVmCpuClusterEditChecker.isApplicable(UnsupportedVmCpuClusterEditChecker.java:23) [bll.jar:]
	at org.ovirt.engine.core.bll.UnsupportedVmCpuClusterEditChecker$Proxy$_$$_WeldClientProxy.isApplicable(Unknown Source) [bll.jar:]
	at org.ovirt.engine.core.bll.GetClusterEditWarningsQuery.lambda$getProblematicEntities$42(GetClusterEditWarningsQuery.java:70) [bll.jar:]
	at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:174) [rt.jar:1.8.0_65]
	at java.util.Iterator.forEachRemaining(Iterator.java:116) [rt.jar:1.8.0_65]
	at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801) [rt.jar:1.8.0_65]
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) [rt.jar:1.8.0_65]
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) [rt.jar:1.8.0_65]
	at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) [rt.jar:1.8.0_65]


Expected results:
Cluster version updated and no issues in the log.

Additional info:
This issue occurs on 3.6 branch as well.
Comment 1 Einav Cohen 2015-12-04 00:39:25 EST
looks like the exception is in the backend -> removing the "[ui]" prefix from the summary (a bit misleading).
Comment 2 Piotr Kliczewski 2015-12-04 08:53:38 EST
I still think that it is UI issue. The cpu type is not validated before sending request to the engine.
Comment 3 Oved Ourfali 2015-12-04 09:09:17 EST
I think the two bugs are different. 
However, it seems related to bug 1261851.

Micahl, can someone at virt take a look? 
Piotr, this might be fixed by a UI validation, but the engine code should throw npe.
Comment 4 Piotr Kliczewski 2015-12-04 09:13:21 EST
I reopened bug 1261851 and marking this as duplicate.

*** This bug has been marked as a duplicate of bug 1261851 ***

Note You need to log in before you can comment on or make changes to this bug.