Bug 1288146 - all events on timeline appear only under the "power activity" event type
all events on timeline appear only under the "power activity" event type
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.6.0
Assigned To: Mooli Tayer
Dafna Ron
container
:
Depends On:
Blocks: 1289623
  Show dependency treegraph
 
Reported: 2015-12-03 11:32 EST by Dafna Ron
Modified: 2016-06-29 11:17 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289623 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screenshots (1.70 MB, application/x-gzip)
2015-12-03 11:32 EST, Dafna Ron
no flags Details
'status' events (128.87 KB, image/png)
2015-12-08 09:45 EST, Mooli Tayer
no flags Details

  None (edit)
Description Dafna Ron 2015-12-03 11:32:55 EST
Created attachment 1101857 [details]
logs and screenshots

Description of problem:

All the events in my setup appear under "power activity" while the events range form create to delete for example. 

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create pods and containers
2. navigate to providers -> select the provider -> select the event type power activity
3. navigate to providers -> select the provider -> select the event type creation/Addition
4. navigate to providers -> select the provider -> select the event type power activity -> select the event -> look at the event details 

**this happens for pods and container pages as well**

Actual results:

All the events appear under the same type which is power activity

Expected results:

they should appear under the appropriate event

Additional info:screenshot and logs
Comment 1 Mooli Tayer 2015-12-08 09:45 EST
Created attachment 1103631 [details]
'status' events
Comment 2 Mooli Tayer 2015-12-08 09:57:49 EST
We do have other types of events (see screenshot)
This is our current list of events by categories;
my suggestions in footnotes

General Activity:
POD_NODESELECTORMISMATCHING[1]

Network:
POD_HOSTPORTCONFLICT

Power Activity:
NODE_REBOOT
POD_SCHEDULED[2]
POD_FAILEDSCHEDULING[1]
REPLICATOR_SUCCESSFULCREATE[2]
REPLICATOR_FAILEDCREATE[1]
CONTAINER_CREATED [2]
CONTAINER_KILLING [1]
CONTAINER_STARTED [2]
CONTAINER_STOPPED [2]

"Alarm/Status change/Errors":
NODE_NODEREADY 
NODE_NODENOTREADY
NODE_FAILEDMOUNT [3]
NODE_INVALIDDISKCAPACITY [3]
POD_FAILEDVALIDATION [1]
POD_DEADLINEEXCEEDED [1]
POD_FAILEDSYNC [1]
POD_INSUFFICIENTFREECPU [1]
CONTAINER_UNHEALTHY [1]

"Storage":
POD_OUTOFDISK 
POD_INSUFFICIENTFREEMEMORY

Other categories:
"Creation/Addition"
"Configuration/Reconfiguration"
"Deletion/Removal"
"General Activity"
"Import / Export"
"Migration/Vmotion"
"Snapshot Activity"
"Alarm/Status change/Errors"

[1] Move to Alarm/Status change/Errors
[2] Move to Creation/Addition
[3] Move to Storage
Comment 3 Mooli Tayer 2015-12-13 10:25:58 EST
submitted upstream: https://github.com/ManageIQ/manageiq/pull/5823/files
Comment 4 Mooli Tayer 2015-12-17 09:13:03 EST
>> John Prause 2015-12-17 09:05:04 EST
>> Status: POST → MODIFIED

I believe this was not merged
Comment 5 Federico Simoncelli 2016-01-04 10:59:05 EST
Mooli shouldn't this be on POST?
Comment 6 Mooli Tayer 2016-01-04 12:20:58 EST
(In reply to Federico Simoncelli from comment #5)
> Mooli shouldn't this be on POST?

right:
merged upstream:
https://github.com/ManageIQ/manageiq/pull/5823
Comment 7 Federico Simoncelli 2016-01-04 12:22:28 EST
(In reply to Mooli Tayer from comment #6)
> (In reply to Federico Simoncelli from comment #5)
> > Mooli shouldn't this be on POST?
> 
> right:
> merged upstream:
> https://github.com/ManageIQ/manageiq/pull/5823

Can you move it to POST? (same for any other 5.6.0 BZ you may have in this state)
Comment 9 errata-xmlrpc 2016-06-29 11:17:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.