Bug 1289623 - all events on timeline appear only under the "power activity" event type
all events on timeline appear only under the "power activity" event type
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
x86_64 Linux
medium Severity medium
: GA
: 5.5.2
Assigned To: Mooli Tayer
Dafna Ron
container
: ZStream
Depends On: 1288146
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 10:32 EST by John Prause
Modified: 2016-02-10 10:26 EST (History)
11 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288146
Environment:
Last Closed: 2016-02-10 10:26:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Prause 2015-12-08 10:32:09 EST
+++ This bug was initially created as a clone of Bug #1288146 +++

Description of problem:

All the events in my setup appear under "power activity" while the events range form create to delete for example. 

Version-Release number of selected component (if applicable):

cfme-5.5.0.13-1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. create pods and containers
2. navigate to providers -> select the provider -> select the event type power activity
3. navigate to providers -> select the provider -> select the event type creation/Addition
4. navigate to providers -> select the provider -> select the event type power activity -> select the event -> look at the event details 

**this happens for pods and container pages as well**

Actual results:

All the events appear under the same type which is power activity

Expected results:

they should appear under the appropriate event

Additional info:screenshot and logs

--- Additional comment from Mooli Tayer on 2015-12-08 09:45 EST ---



--- Additional comment from Mooli Tayer on 2015-12-08 09:57:49 EST ---

We do have other types of events (see screenshot)
This is our current list of events by categories;
my suggestions in footnotes

General Activity:
POD_NODESELECTORMISMATCHING[1]

Network:
POD_HOSTPORTCONFLICT

Power Activity:
NODE_REBOOT
POD_SCHEDULED[2]
POD_FAILEDSCHEDULING[1]
REPLICATOR_SUCCESSFULCREATE[2]
REPLICATOR_FAILEDCREATE[1]
CONTAINER_CREATED [2]
CONTAINER_KILLING [1]
CONTAINER_STARTED [2]
CONTAINER_STOPPED [2]

"Alarm/Status change/Errors":
NODE_NODEREADY 
NODE_NODENOTREADY
NODE_FAILEDMOUNT [3]
NODE_INVALIDDISKCAPACITY [3]
POD_FAILEDVALIDATION [1]
POD_DEADLINEEXCEEDED [1]
POD_FAILEDSYNC [1]
POD_INSUFFICIENTFREECPU [1]
CONTAINER_UNHEALTHY [1]

"Storage":
POD_OUTOFDISK 
POD_INSUFFICIENTFREEMEMORY

Other categories:
"Creation/Addition"
"Configuration/Reconfiguration"
"Deletion/Removal"
"General Activity"
"Import / Export"
"Migration/Vmotion"
"Snapshot Activity"
"Alarm/Status change/Errors"

[1] Move to Alarm/Status change/Errors
[2] Move to Creation/Addition
[3] Move to Storage
Comment 2 Mooli Tayer 2015-12-13 10:26:18 EST
submitted upstream: https://github.com/ManageIQ/manageiq/pull/5823/files
Comment 3 Mooli Tayer 2016-01-04 12:34:56 EST
merged upstream:
https://github.com/ManageIQ/manageiq/pull/5823/files
Comment 7 Dafna Ron 2016-01-19 09:01:09 EST
verified on cfme-5.5.2.1-1.el7cf.x86_64
Comment 8 errata-xmlrpc 2016-02-10 10:26:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.