Bug 1288243 - After creating a firewall rule you can not access the rule tab in horizon [NEEDINFO]
After creating a firewall rule you can not access the rule tab in horizon
Status: CLOSED DUPLICATE of bug 1291996
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-fwaas (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 7.0 (Kilo)
Assigned To: Assaf Muller
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 17:44 EST by Jeremy
Modified: 2017-06-05 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-05 09:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amuller: needinfo? (jmelvin)


Attachments (Terms of Use)

  None (edit)
Description Jeremy 2015-12-03 17:44:18 EST
Description of problem:After creating a firewall rule, there are python errors when you go to the rule tab in horizon.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.creat firewall rule from the cli or horizon. 
2.Then the firewall rule tab shows python errors. The same erros are seen in the logs
3.

Actual results:


Expected results:


Additional info:
2015-12-03 12:06:36.264 23039 DEBUG neutron_fwaas.db.firewall.firewall_router_insertion_db [req-5136f086-69d1-4a76-a562-b3196387b15a ] neutron_fwaas.services.firewall.fwaas_plugin.FirewallPlugin method get_firewall_routers called with arguments (<neutron.context.Context object at 0x54228d0>, u'161aa337-5070-468f-821c-2e772f44a3d0') {} wrapper /usr/lib/python2.7/site-packages/neutron/common/log.py:33
2015-12-03 12:06:36.269 23039 ERROR neutron.api.v2.resource [req-5136f086-69d1-4a76-a562-b3196387b15a ] index failed
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource Traceback (most recent call last):
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/resource.py", line 83, in resource
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     result = method(request=request, **args)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/base.py", line 319, in index
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     return self._items(request, True, parent_id)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/base.py", line 249, in _items
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     obj_list = obj_getter(request.context, **kwargs)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron_fwaas/services/firewall/fwaas_plugin.py", line 381, in get_firewalls
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     fw_current_rtrs = self.get_firewall_routers(context, fw['id'])
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/common/log.py", line 34, in wrapper
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     return method(*args, **kwargs)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron_fwaas/db/firewall/firewall_router_insertion_db.py", line 61, in get_firewall_routers
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     fw_rtrs = [entry.router_id for entry in fw_rtr_rows]
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/orm/query.py", line 2516, in __iter__
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     return self._execute_and_instances(context)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/orm/query.py", line 2531, in _execute_and_instances
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     result = conn.execute(querycontext.statement, self._params)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/base.py", line 914, in execute
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     return meth(self, multiparams, params)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/sql/elements.py", line 323, in _execute_on_connection
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     return connection._execute_clauseelement(self, multiparams, params)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/base.py", line 1010, in _execute_clauseelement
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     compiled_sql, distilled_params
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/base.py", line 1146, in _execute_context
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     context)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/base.py", line 1337, in _handle_dbapi_exception
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     util.raise_from_cause(newraise, exc_info)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/util/compat.py", line 199, in raise_from_cause
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     reraise(type(exception), exception, tb=exc_tb)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/base.py", line 1139, in _execute_context
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     context)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/sqlalchemy/engine/default.py", line 450, in do_execute
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     cursor.execute(statement, parameters)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/MySQLdb/cursors.py", line 174, in execute
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     self.errorhandler(self, exc, value)
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource   File "/usr/lib64/python2.7/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource     raise errorclass, errorvalue
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource ProgrammingError: (_mysql_exceptions.ProgrammingError) (1146, "Table 'ovs_neutron.firewall_router_associations' doesn't exist") [SQL: u'SELECT firewall_router_associations.router_id AS firewall_router_associations_router_id \nFROM firewall_router_associations \nWHERE firewall_router_associations.fw_id = %s'] [parameters: ('161aa337-5070-468f-821c-2e772f44a3d0',)]
2015-12-03 12:06:36.269 23039 TRACE neutron.api.v2.resource
2015-12-03 12:06:36.274 23039 INFO neutron.wsgi [req-5136f086-69d1-4a76-a562-b3196387b15a ] 10.24.101.35 - - [03/Dec/2015 12:06:
Comment 2 Assaf Muller 2015-12-03 19:34:08 EST
Can you list FW rules from the CLI, or does it result in the same error?

The missing table error implies that neutron-db-manage ("neutron-db-manage --service fwaas --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade head") was not run to create the FW DB tables. Are you able to execute *any* FW operations? Create policy/rule/fw?
Comment 3 Jeremy 2015-12-07 15:03:27 EST
we can list fw rules from the cli. The problem only seems to be with horizon after creating rules. We can still create firewall, policy but not able to see the rules in horizon after creating a rule.
Comment 4 Sarainia 2016-04-05 19:41:03 EDT
This my bug ID 1323573 I made the complaint late on the 4th and have not got the Assigned person working on my case still! I also pasted this bug on Youtube but again no replies? Surely somebody knows what's going on right? To begin with I am not even sure my bug is in the Right area as it's a programming or a compiling thing that I am working on to make a proper Operating System as all Operating Systems from Apple/Microsoft/Linux even seem to mess up in all the wrong areas that I am trying to get around! The main thing with linux is I can't even install Adobe Flash or even Avast Anti Virus, so if I can't even find that by downloading and opening up my Package Downloader GUI then how do I get anywhere but my bug is 1323573 hopefully soon we can get my issue resolved someway somehow!
Comment 6 Jon Schlueter 2016-04-18 07:29:01 EDT
Looks like we need to go search the launchpad bugs for horizon and file one there if it reproduces upstream.
Comment 7 Assaf Muller 2016-06-03 21:52:17 EDT
I believe this is a duplicate of RHBZ 1291996. Can you reproduce with python-django-horizon-2015.1.3-1.el7ost?
Comment 8 Assaf Muller 2017-06-05 09:59:23 EDT

*** This bug has been marked as a duplicate of bug 1291996 ***

Note You need to log in before you can comment on or make changes to this bug.