Bug 1288399 - [openshift-doc] log aggregation doc doesn't mentioned about deploy command
[openshift-doc] log aggregation doc doesn't mentioned about deploy command
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: brice
Vikram Goyal
Vikram Goyal
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-04 01:19 EST by Kenjiro Nakayama
Modified: 2016-02-04 23:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 23:43:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-12-04 01:19:58 EST
https://docs.openshift.com/enterprise/3.1/install_config/aggregate_logging.html#post-deployment-configuration

Need deploy command below:

  oc deploy --latest logging-es-...

Without above command, they are not deployed.

I'm not going to go into details, please refer upstream doc - https://github.com/openshift/origin-aggregated-logging/blob/master/deployment/README.md
Comment 1 Ryan Howe 2015-12-08 17:43:31 EST

*** This bug has been marked as a duplicate of bug 1288402 ***
Comment 2 brice 2016-01-29 01:03:54 EST
Kenjiro,

I can't tell too much from the BZ description. Are you suggesting that the "Adjusting ElasticSearch After Deployment" section be added into the docs? From what i can tell, that's where the example you use above is discussed.

Also, I'm not sure if that matches what I'm seeing in the customer case. Was their problem with Elasticsearch and post-configuration?
Comment 3 Kenjiro Nakayama 2016-02-01 23:57:56 EST
Brice,

I understand this cause of my report.

As I filed this ticket:

  https://bugzilla.redhat.com/show_bug.cgi?id=1288414#c4

the "IS" hasn't been populated for some reason on my env and I modified the DC by myself.
After modified the DC, I also needed to run "oc deploy --latest ..." to deploy them.

However, the reason I modified the DC, it was not a bug (Some other reason but it is not sure.)

If the "IS" is populated, running "oc deploy --latest" is not necessary. Please close this ticket as "Not a bug".
Comment 4 brice 2016-02-04 23:43:03 EST
Kenjiro,

Sure. I will close this BZ. Please let me know if this issue comes up again.

Note You need to log in before you can comment on or make changes to this bug.